[<prev] [next>] [day] [month] [year] [list]
Message-ID: <57A063BB.7000708@laposte.net>
Date: Tue, 2 Aug 2016 11:11:23 +0200
From: Sebastian Frias <sf84@...oste.net>
To: Grant Likely <grant.likely@...retlab.ca>,
Thomas Gambier <Thomas_Gambier@...madesigns.com>,
Marc Zyngier <marc.zyngier@....com>,
Jason Cooper <jason@...edaemon.net>
Cc: LKML <linux-kernel@...r.kernel.org>, Mason <slash.tmp@...e.fr>
Subject: [PATCH 2/2] irqdomain: factorise irq_domain_xlate_onetwocell()
Commit 16b2e6e2f31d ("irq_domain: Create common xlate functions that device
drivers can use") introduced three similar functions:
irq_domain_xlate_onecell()
irq_domain_xlate_twocell()
irq_domain_xlate_onetwocell()
yet the last one, irq_domain_xlate_onetwocell(), can be factored to use the
two previous ones to avoid code duplication.
Signed-off-by: Sebastian Frias <sf84@...oste.net>
---
kernel/irq/irqdomain.c | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/kernel/irq/irqdomain.c b/kernel/irq/irqdomain.c
index 1bdd3fe..28c09ab 100644
--- a/kernel/irq/irqdomain.c
+++ b/kernel/irq/irqdomain.c
@@ -821,14 +821,12 @@ int irq_domain_xlate_onetwocell(struct irq_domain *d,
const u32 *intspec, unsigned int intsize,
unsigned long *out_hwirq, unsigned int *out_type)
{
- if (WARN_ON(intsize < 1))
- return -EINVAL;
- *out_hwirq = intspec[0];
if (intsize > 1)
- *out_type = intspec[1] & IRQ_TYPE_SENSE_MASK;
+ return irq_domain_xlate_twocell(d, ctrlr, intspec, intsize,
+ out_hwirq, out_type);
else
- *out_type = IRQ_TYPE_NONE;
- return 0;
+ return irq_domain_xlate_onecell(d, ctrlr, intspec, intsize,
+ out_hwirq, out_type);
}
EXPORT_SYMBOL_GPL(irq_domain_xlate_onetwocell);
--
1.7.11.2
Powered by blists - more mailing lists