[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802104423.23479-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 18:44:23 +0800
From: Baole Ni <baolex.ni@...el.com>
To: mchehab@...nel.org, maurochehab@...il.com, mchehab@...radead.org,
mchehab@...hat.com, m.chehab@...sung.com,
dougthompson@...ssion.com, bp@...en8.de
Cc: linux-edac@...r.kernel.org, linux-kernel@...r.kernel.org,
chuansheng.liu@...el.com, baolex.ni@...el.com, lee.jones@...aro.org
Subject: [PATCH 0146/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/edac/i3200_edac.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/edac/i3200_edac.c b/drivers/edac/i3200_edac.c
index 1f45338..b2d5f92 100644
--- a/drivers/edac/i3200_edac.c
+++ b/drivers/edac/i3200_edac.c
@@ -546,5 +546,5 @@ MODULE_LICENSE("GPL");
MODULE_AUTHOR("Akamai Technologies, Inc.");
MODULE_DESCRIPTION("MC support for Intel 3200 memory hub controllers");
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
--
2.9.2
Powered by blists - more mailing lists