[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802104017.20091-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 18:40:17 +0800
From: Baole Ni <baolex.ni@...el.com>
To: mst@...hat.com, pjk1939@...ux.vnet.ibm.com, pavel@....cz,
gregkh@...uxfoundation.org, hpa@...or.com, x86@...nel.org
Cc: virtualization@...ts.linux-foundation.org,
linux-kernel@...r.kernel.org, chuansheng.liu@...el.com,
baolex.ni@...el.com, martin.petersen@...cle.com,
kent.overstreet@...il.com
Subject: [PATCH 0095/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/block/virtio_blk.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block/virtio_blk.c b/drivers/block/virtio_blk.c
index 42758b5..786a393 100644
--- a/drivers/block/virtio_blk.c
+++ b/drivers/block/virtio_blk.c
@@ -561,7 +561,7 @@ static struct blk_mq_ops virtio_mq_ops = {
};
static unsigned int virtblk_queue_depth;
-module_param_named(queue_depth, virtblk_queue_depth, uint, 0444);
+module_param_named(queue_depth, virtblk_queue_depth, uint, S_IRUSR | S_IRGRP | S_IROTH);
static int virtblk_probe(struct virtio_device *vdev)
{
--
2.9.2
Powered by blists - more mailing lists