[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802104550.24672-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 18:45:50 +0800
From: Baole Ni <baolex.ni@...el.com>
To: mchehab@...nel.org, maurochehab@...il.com, mchehab@...radead.org,
mchehab@...hat.com, m.chehab@...sung.com, lho@....com,
dougthompson@...ssion.com, bp@...en8.de
Cc: linux-kernel@...r.kernel.org, chuansheng.liu@...el.com,
baolex.ni@...el.com, lee.jones@...aro.org
Subject: [PATCH 0164/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/eisa/virtual_root.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/eisa/virtual_root.c b/drivers/eisa/virtual_root.c
index 535e4f9..2242564 100644
--- a/drivers/eisa/virtual_root.c
+++ b/drivers/eisa/virtual_root.c
@@ -69,6 +69,6 @@ static int __init virtual_eisa_root_init (void)
return 0;
}
-module_param (force_probe, int, 0444);
+module_param (force_probe, int, S_IRUSR | S_IRGRP | S_IROTH);
device_initcall (virtual_eisa_root_init);
--
2.9.2
Powered by blists - more mailing lists