[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20160802092548.74230490@gandalf.local.home>
Date: Tue, 2 Aug 2016 09:25:48 -0400
From: Steven Rostedt <rostedt@...dmis.org>
To: Baole Ni <baolex.ni@...el.com>
Cc: john.stultz@...aro.org, tglx@...utronix.de,
mathieu.desnoyers@...icios.com, jiangshanlai@...il.com,
m.chehab@...sung.com, gregkh@...uxfoundation.org,
m.szyprowski@...sung.com, kyungmin.park@...sung.com,
k.kozlowski@...sung.com, linux-kernel@...r.kernel.org,
chuansheng.liu@...el.com, mhocko@...e.com, vkuznets@...hat.com,
pmladek@...e.com, tj@...nel.org, jpoimboe@...hat.com
Subject: Re: [PATCH 1076/1285] Replace numeric parameter like 0444 with
macro
On Tue, 2 Aug 2016 20:14:16 +0800
Baole Ni <baolex.ni@...el.com> wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
NACK!
I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.
-- Steve
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> kernel/time/sched_clock.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/time/sched_clock.c b/kernel/time/sched_clock.c
> index a26036d..9d072c3 100644
> --- a/kernel/time/sched_clock.c
> +++ b/kernel/time/sched_clock.c
> @@ -71,7 +71,7 @@ struct clock_data {
> static struct hrtimer sched_clock_timer;
> static int irqtime = -1;
>
> -core_param(irqtime, irqtime, int, 0400);
> +core_param(irqtime, irqtime, int, S_IRUSR);
>
> static u64 notrace jiffy_sched_clock_read(void)
> {
Powered by blists - more mailing lists