[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20160802092631.1efe07b5@gandalf.local.home>
Date: Tue, 2 Aug 2016 09:26:31 -0400
From: Steven Rostedt <rostedt@...dmis.org>
To: Baole Ni <baolex.ni@...el.com>
Cc: ddstreet@...e.org, jiangshanlai@...il.com,
mathieu.desnoyers@...icios.com, m.chehab@...sung.com,
gregkh@...uxfoundation.org, m.szyprowski@...sung.com,
kyungmin.park@...sung.com, k.kozlowski@...sung.com,
linux-kernel@...r.kernel.org, chuansheng.liu@...el.com,
mhocko@...e.com, tglx@...utronix.de, vkuznets@...hat.com,
pmladek@...e.com, tj@...nel.org, jpoimboe@...hat.com
Subject: Re: [PATCH 1079/1285] Replace numeric parameter like 0444 with
macro
On Tue, 2 Aug 2016 20:14:31 +0800
Baole Ni <baolex.ni@...el.com> wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
NACK!
I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.
-- Steve
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> lib/842/842_compress.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/lib/842/842_compress.c b/lib/842/842_compress.c
> index 4051339..bf45ea3 100644
> --- a/lib/842/842_compress.c
> +++ b/lib/842/842_compress.c
> @@ -42,7 +42,7 @@
> * so that any length buffer can be compressed.
> */
> static bool sw842_strict;
> -module_param_named(strict, sw842_strict, bool, 0644);
> +module_param_named(strict, sw842_strict, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>
> static u8 comp_ops[OPS_MAX][5] = { /* params size in bits */
> { I8, N0, N0, N0, 0x19 }, /* 8 */
Powered by blists - more mailing lists