[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87zioa2nn4.fsf@linux.intel.com>
Date: Thu, 18 Aug 2016 16:49:03 +0300
From: Felipe Balbi <balbi@...nel.org>
To: Javier Martinez Canillas <javier@....samsung.com>,
linux-kernel@...r.kernel.org
Cc: Javier Martinez Canillas <javier@....samsung.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-usb@...r.kernel.org
Subject: Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module
Javier Martinez Canillas <javier@....samsung.com> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@....samsung.com>
Acked-by: Felipe Balbi <felipe.balbi@...ux.intel.com>
> ---
>
> drivers/usb/gadget/udc/omap_udc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
> index 9b7d39484ed3..a8709f9e5648 100644
> --- a/drivers/usb/gadget/udc/omap_udc.c
> +++ b/drivers/usb/gadget/udc/omap_udc.c
> @@ -2875,7 +2875,7 @@ bad_on_1710:
> xceiv = NULL;
> /* "udc" is now valid */
> pullup_disable(udc);
> -#if defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
> +#if IS_ENABLED(CONFIG_USB_OHCI_HCD)
> udc->gadget.is_otg = (config->otg != 0);
> #endif
>
> --
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
--
balbi
Download attachment "signature.asc" of type "application/pgp-signature" (801 bytes)
Powered by blists - more mailing lists