lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 19 Aug 2016 14:34:56 +0100
From:   Punit Agrawal <punit.agrawal@....com>
To:     Will Deacon <will.deacon@....com>
Cc:     kvm@...r.kernel.org, Marc Zyngier <marc.zyngier@....com>,
        Catalin Marinas <catalin.marinas@....com>,
        linux-kernel@...r.kernel.org, Steven Rostedt <rostedt@...dmis.org>,
        Ingo Molnar <mingo@...hat.com>, kvmarm@...ts.cs.columbia.edu,
        linux-arm-kernel@...ts.infradead.org
Subject: Re: [RFC PATCH 4/7] arm64: tlbflush.h: add __tlbi() macro

Will Deacon <will.deacon@....com> writes:

> On Tue, Aug 16, 2016 at 11:45:09AM +0100, Punit Agrawal wrote:
>> From: Mark Rutland <mark.rutland@....com>
>> 
>> As with dsb() and isb(), add a __tbli() helper so that we can avoid
>
> Minor typo: s/__tbli/__tlbi/

Thanks for spotting. I've fixed this locally now.

>
>> distracting asm boilerplate every time we want a TLBI. As some TLBI
>> operations take an argument while others do not, some pre-processor is
>> used to handle these two cases with different assembly blocks.
>> 
>> The existing tlbflush.h code is moved over to use the helper.
>> 
>> Signed-off-by: Mark Rutland <mark.rutland@....com>
>> Cc: Catalin Marinas <catalin.marinas@....com>
>> Cc: Marc Zyngier <marc.zyngier@....com>
>> Cc: Will Deacon <will.deacon@....com>
>> [ rename helper to __tlbi, update commit log ]
>> Signed-off-by: Punit Agrawal <punit.agrawal@....com>
>> ---
>>  arch/arm64/include/asm/tlbflush.h | 31 +++++++++++++++++++++++--------
>>  1 file changed, 23 insertions(+), 8 deletions(-)
>> 
>> diff --git a/arch/arm64/include/asm/tlbflush.h b/arch/arm64/include/asm/tlbflush.h
>> index b460ae2..d57a0be 100644
>> --- a/arch/arm64/include/asm/tlbflush.h
>> +++ b/arch/arm64/include/asm/tlbflush.h
>> @@ -25,6 +25,21 @@
>>  #include <asm/cputype.h>
>>  
>>  /*
>> + * Raw TLBI operations. Drivers and most kernel code should use the TLB
>> + * management routines below in preference to these. Where necessary, these can
>> + * be used to avoid asm() boilerplate.
>> + *
>> + * Can be used as __tlbi(op) or __tlbi(op, arg), depending on whether a
>> + * particular TLBI op takes an argument or not. The macros below handle invoking
>> + * the asm with or without the register argument as appropriate.
>> + */
>> +#define TLBI_0(op, arg)		asm ("tlbi " #op)
>> +#define TLBI_1(op, arg)		asm ("tlbi " #op ", %0" : : "r" (arg))
>> +#define TLBI_N(op, arg, n, ...)	TLBI_##n(op, arg)
>
> Should this be prefixed with underscores, too?

As these were only used in the definition of __tlbi() I didn't
prefix them. I'll add them for the next posting.

Thanks for taking a look.

Punit

>
> Will
> _______________________________________________
> kvmarm mailing list
> kvmarm@...ts.cs.columbia.edu
> https://lists.cs.columbia.edu/mailman/listinfo/kvmarm

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ