[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20160913065259.GA31898@dhcp22.suse.cz>
Date: Tue, 13 Sep 2016 08:53:01 +0200
From: Michal Hocko <mhocko@...nel.org>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-mm@...ck.org, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] fs: use mapping_set_error instead of opencoded
set_bit
On Mon 12-09-16 15:18:23, Andrew Morton wrote:
> On Mon, 12 Sep 2016 15:11:46 -0700 Andrew Morton <akpm@...ux-foundation.org> wrote:
>
> > > @@ -409,7 +408,7 @@ static int afs_write_back_from_locked_page(struct afs_writeback *wb,
> > > case -ENOMEDIUM:
> > > case -ENXIO:
> > > afs_kill_pages(wb->vnode, true, first, last);
> > > - set_bit(AS_EIO, &wb->vnode->vfs_inode.i_mapping->flags);
> > > + mapping_set_error(wb->vnode->vfs_inode.i_mapping, -ENXIO);
> >
> > This one is a functional change: mapping_set_error() will rewrite
> > -ENXIO into -EIO. Doesn't seem at all important though.
>
> hm, OK, it's not a functional change - the code was already doing
> s/ENXIO/EIO/.
Yes the rewrite is silent but I've decided to keep the current errno
because I have no idea whether this can change in future. It doesn't
sound probable but it also sounds safer to do an overwrite at a single
place rather than all over the place /me thinks.
> Let's make it look more truthful?
>
> --- a/fs/afs/write.c~fs-use-mapping_set_error-instead-of-opencoded-set_bit-fix
> +++ a/fs/afs/write.c
> @@ -408,7 +408,7 @@ no_more:
> case -ENOMEDIUM:
> case -ENXIO:
> afs_kill_pages(wb->vnode, true, first, last);
> - mapping_set_error(wb->vnode->vfs_inode.i_mapping, -ENXIO);
> + mapping_set_error(wb->vnode->vfs_inode.i_mapping, -EIO);
> break;
> case -EACCES:
> case -EPERM:
> _
>
>
--
Michal Hocko
SUSE Labs
Powered by blists - more mailing lists