[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <bd7d2e5f-9d34-8e33-602d-8f0acccb1f7e@redhat.com>
Date: Fri, 23 Sep 2016 11:35:16 +0200
From: Paolo Bonzini <pbonzini@...hat.com>
To: Radim Krčmář <rkrcmar@...hat.com>,
linux-kernel@...r.kernel.org, kvm@...r.kernel.org
Cc: Wanpeng Li <kernellwp@...il.com>
Subject: Re: [PATCH] KVM: VMX: refactor global page-sized bitmaps
On 23/09/2016 01:18, Radim Krčmář wrote:
> We've had 10 page-sized bitmaps that were being allocated and freed one
> by one when we could just use a cycle and MSR bitmaps had a lot of
> useless code lying around.
>
> This patch
> * enumerates vmx bitmaps and uses an array to store them
> * replaces vmx_enable_intercept_msr_read_x2apic() with a condition
> * joins vmx_msr_disable_intercept_msr_{read,write}_x2apic()
> * renames x2apic_apicv_inactive msr_bitmaps to x2apic and original
> x2apic bitmaps to x2apic_apicv
It's almost like this could be split in four patches! :) Seriously, I
like it very much but it's very hard to review.
Also, while it's a good idea to keep the bitmaps in an array,
vmx_bitmaps[vmread_bitmap] is not very readable. Please make the enum
uppercase, and possibly add
#define vmread_bitmap (vmx_bitmaps[VMREAD_BITMAP])
Thanks!
Paolo
> Signed-off-by: Radim Krčmář <rkrcmar@...hat.com>
Powered by blists - more mailing lists