lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 24 Sep 2016 19:24:14 -0500
From:   Steve Kenton <skenton@...edu>
To:     <linux-pci@...r.kernel.org>
CC:     <linux-kernel@...r.kernel.org>,
        Bjorn Helgaas <bhelgaas@...gle.com>,
        yinghai Lu <yinghai@...nel.org>,
        Blackmagic Developer Support <developer@...ckmagicdesign.com>
Subject: lspci not showing motherboard ethernet controller after PCIe card
 firmware update change from 32-bit to 64-bit BAR

I have two different systems with Blackmagic Design Intensity Pro-4K
cards. One uses an ECS H81H3-I motherboard and the other uses a Gigabyte
GA-H110N motherboard. Previously both were working properly. When I
upgraded the Blackmagic Design desktopvideo package from version 10.7 to
version 10.8 it included an update of the firmware on the cards from
version 0x85 to 0xbd. After the  upgrade the Gigabyte-motherboard system
continues to work properly, but the ECS-motherboard system no longer
shows the motherboard ethernet controller with lspci. Downgrading the
firmware makes the ethernet controller reappear with lspci. Upgrading
again makes it disappear again. Attached are the output of lscpi -vv
for each version of the firmware on the ECS-motherboard system.
Upgrading to the most recent ECS-motherboard bios did not have any effect.

There are a number of differences in the two lspci outputs but
based on conversations I've seen on LKM, which I peruse but am not
subscribed to, I suspect that this is the important one:

lspci-Intensity-Pro-4K-10.7-firmware.txt:    Region 0: Memory at
f7d00000 (32-bit, non-prefetchable) [size=1M]
lspci-Intensity-Pro-4K-10.8-firmware.txt:    Region 0: Memory at
f7c00000 (64-bit, non-prefetchable) [size=1M]

The Engineers at Blackmagic Design have confirmed that the change to a
64-bit BAR with firmware version 0xbd was intentional and correct. And
to be clear, the Blackmagic cards continue to work properly. The issue
is the motherboard ethernet controller disappearing after upgrading the
Blackmagic cards to new firmware with a 64-bit BAR. Note, however, that
64-bit BAR is below 4GB with the high four bytes being all zeros. After
the firmware update it's like there is "no room at the inn" for the
motherboard ethernet controller so it never gets enabled. I think we can
all agree that it's a likely a problem with the PC motherboard bios. I'm
hoping to find a workaround to allow me to configure a number of
existing ECS-motherboard systems in the field for use with the new firmware.

I normally run Ubuntu 14.04 LTS and tried the most recent 4.4.0-38
kernel but then I noticed that the Ubuntu 16.10 daily build ISO switched
to kernel 4.8-RC-something on Sept 21st. So I booted that
livedvd and tried it to see if 4.8-RC included some recent PCIe
32-bit/64-bit resource fix but sadly the results were the same. With
firmware 0xbd, the ethernet controller was still missing from the lspci
output. I poked around with various of the kernel pci= parameters such
as bios and nobios to no avail, but I really am out of my depth here.

I'm available to run tests if anyone has any suggestions.

Steve Kenton


View attachment "dmesg-firmware0x85.txt" of type "text/plain" (65617 bytes)

View attachment "dmesg-firmware0xbd-pci=bios.txt" of type "text/plain" (64598 bytes)

View attachment "dmesg-firmware0xbd-pci=nobios.txt" of type "text/plain" (64240 bytes)

View attachment "lspcivv-firmware0x85.txt" of type "text/plain" (24471 bytes)

View attachment "lspcivv-firmware0xbd-pci=bios.txt" of type "text/plain" (20838 bytes)

View attachment "lspcivv-firmware0xbd-pci=nobios.txt" of type "text/plain" (20838 bytes)

Powered by blists - more mailing lists