[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20161020201206.GB2734@joana>
Date: Thu, 20 Oct 2016 18:12:06 -0200
From: Gustavo Padovan <gustavo@...ovan.org>
To: Brian Starkey <brian.starkey@....com>
Cc: dri-devel@...ts.freedesktop.org, marcheu@...gle.com,
Daniel Stone <daniels@...labora.com>, seanpaul@...gle.com,
Daniel Vetter <daniel.vetter@...ll.ch>,
linux-kernel@...r.kernel.org, laurent.pinchart@...asonboard.com,
Gustavo Padovan <gustavo.padovan@...labora.co.uk>,
John Harrison <John.C.Harrison@...el.com>, m.chehab@...sung.com
Subject: Re: [PATCH v5 3/4] drm/fence: add fence timeline to drm_crtc
2016-10-20 Brian Starkey <brian.starkey@....com>:
> Hi Gustavo,
>
> On Thu, Oct 20, 2016 at 12:50:04PM -0200, Gustavo Padovan wrote:
> > From: Gustavo Padovan <gustavo.padovan@...labora.co.uk>
> >
> > Create one timeline context for each CRTC to be able to handle out-fences
> > and signal them. It adds a few members to struct drm_crtc: fence_context,
> > where we store the context we get from fence_context_alloc(), the
> > fence seqno and the fence lock, that we pass in fence_init() to be
> > used by the fence.
> >
> > v2: Comment by Daniel Stone:
> > - add BUG_ON() to fence_to_crtc() macro
> >
> > v3: Comment by Ville Syrjälä
> > - Use more meaningful name as crtc timeline name
> >
> > Signed-off-by: Gustavo Padovan <gustavo.padovan@...labora.co.uk>
> > ---
> > drivers/gpu/drm/drm_crtc.c | 31 +++++++++++++++++++++++++++++++
> > include/drm/drm_crtc.h | 19 +++++++++++++++++++
> > 2 files changed, 50 insertions(+)
> >
> > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> > index fcb6453..b99090f 100644
> > --- a/drivers/gpu/drm/drm_crtc.c
> > +++ b/drivers/gpu/drm/drm_crtc.c
> > @@ -165,6 +165,32 @@ static void drm_crtc_crc_fini(struct drm_crtc *crtc)
> > #endif
> > }
> >
> > +static const char *drm_crtc_fence_get_driver_name(struct fence *fence)
> > +{
> > + struct drm_crtc *crtc = fence_to_crtc(fence);
> > +
> > + return crtc->dev->driver->name;
> > +}
> > +
> > +static const char *drm_crtc_fence_get_timeline_name(struct fence *fence)
> > +{
> > + struct drm_crtc *crtc = fence_to_crtc(fence);
> > +
> > + return crtc->timeline_name;
> > +}
> > +
> > +static bool drm_crtc_fence_enable_signaling(struct fence *fence)
> > +{
> > + return true;
> > +}
> > +
> > +const struct fence_ops drm_crtc_fence_ops = {
> > + .get_driver_name = drm_crtc_fence_get_driver_name,
> > + .get_timeline_name = drm_crtc_fence_get_timeline_name,
> > + .enable_signaling = drm_crtc_fence_enable_signaling,
> > + .wait = fence_default_wait,
> > +};
> > +
> > /**
> > * drm_crtc_init_with_planes - Initialise a new CRTC object with
> > * specified primary and cursor planes.
> > @@ -222,6 +248,11 @@ int drm_crtc_init_with_planes(struct drm_device *dev, struct drm_crtc *crtc,
> > return -ENOMEM;
> > }
> >
> > + crtc->fence_context = fence_context_alloc(1);
> > + spin_lock_init(&crtc->fence_lock);
> > + snprintf(crtc->timeline_name, sizeof(crtc->timeline_name),
> > + "drm_crtc-%d", crtc->base.id);
>
> I wondered about "[CRTC:id:name]" to be consistent with the DRM debug
> prints.
Yeah, sounds good to me.
>
> > +
> > crtc->base.properties = &crtc->properties;
> >
> > list_add_tail(&crtc->head, &config->crtc_list);
> > diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> > index 279132e..657a33a 100644
> > --- a/include/drm/drm_crtc.h
> > +++ b/include/drm/drm_crtc.h
> > @@ -32,6 +32,8 @@
> > #include <linux/fb.h>
> > #include <linux/hdmi.h>
> > #include <linux/media-bus-format.h>
> > +#include <linux/srcu.h>
> > +#include <linux/fence.h>
> > #include <uapi/drm/drm_mode.h>
> > #include <uapi/drm/drm_fourcc.h>
> > #include <drm/drm_modeset_lock.h>
> > @@ -618,6 +620,9 @@ struct drm_crtc_funcs {
> > * @gamma_store: gamma ramp values
> > * @helper_private: mid-layer private data
> > * @properties: property tracking for this CRTC
> > + * @fence_context: context for fence signalling
> > + * @fence_lock: fence lock for the fence context
> > + * @fence_seqno: seqno variable to create fences
>
> @timeline_name ?
Sure.
Gustavo
Powered by blists - more mailing lists