[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1477692289-37412-1-git-send-email-fenghua.yu@intel.com>
Date: Fri, 28 Oct 2016 15:04:39 -0700
From: "Fenghua Yu" <fenghua.yu@...el.com>
To: "Thomas Gleixner" <tglx@...utronix.de>
Cc: "Ingo Molnar" <mingo@...e.hu>,
"H. Peter Anvin" <h.peter.anvin@...el.com>,
"Tony Luck" <tony.luck@...el.com>, "Borislav Petkov" <bp@...e.de>,
"Stephane Eranian" <eranian@...gle.com>,
"Peter Zijlstra" <peterz@...radead.org>,
"Dave Hansen" <dave.hansen@...el.com>,
"David Carrillo-Cisneros" <davidcc@...gle.com>,
"Ravi V Shankar" <ravi.v.shankar@...el.com>,
"Vikas Shivappa" <vikas.shivappa@...ux.intel.com>,
"Sai Prakhya" <sai.praneeth.prakhya@...el.com>,
"Nilay Vaish" <nilayvaish@...il.com>, "Shaohua Li" <shli@...com>,
"linux-kernel" <linux-kernel@...r.kernel.org>,
"x86" <x86@...nel.org>, "Fenghua Yu" <fenghua.yu@...el.com>
Subject: [PATCH v6 00/10] Intel Cache Allocation Technology
From: Fenghua Yu <fenghua.yu@...el.com>
This version is supposed to cover all comments from Thomas.
Patch 1-4, 6-9 of 18 v5 patches are in tip x86/cache branch. We
have rest of 10 patches in v6 on top of tip tree.
Change log in v6:
patch 1 (i.e. patch 5 in v5): Change max_cbm_val to cbm_mask.
patch 2 (i.e. patch 10 in v5): Change comments for rdt_find_domain and
domain_add_cpu() to explain why domain list is sorted by id. Change
the pos argument to optional in rdt_rind_domain and assign NULL to it
in caller domain_remove_cpu.
patch 3 (i.e. patch 11 in v5): Remove arg's type cast in
l3_qos_cfg_update(). Change the local variable declaration lines in
more readable way. Disable CDP in umount only when it's enabled. Fix
an error handling issue in rdt_mount.
patch 4 (i.e. patch 12 in v5): Change names from "num_closid" to
"num_closids" and from "cbm_val" to "cbm_mask" in res_info_files. Remove
the unused label "out" in rdtgroup_setup_root() and will add it later when
it's used.
patch 5 (i.e. patch 13 in v5): Init closid_free_map by minimal closid
instead of by maximum closid in all resources.
patch 6 (i.e. patch 14 in v5): Change local variable declaration lines
to more readable way.
patch 7 (i.e. patch 15 in v5): Change for_each_process to
for_each_process_thread
patch 8 (i.e. patch 16 in v5): Change local variable declaration lines
to more readable way.
patch 9 (i.e. patch 17 in v5): No change.
patch 10 (i.e. patch 18 in v5): No change.
Fenghua Yu (7):
Documentation, x86: Documentation for Intel resource allocation user
interface
x86/intel_rdt: Add basic resctrl filesystem support
x86/intel_rdt: Add "info" files to resctrl file system
x86/intel_rdt: Add mkdir to resctrl file system
x86/intel_rdt: Add tasks files
x86/intel_rdt: Add scheduler hook
MAINTAINERS: Add maintainer for Intel RDT resource allocation
Tony Luck (3):
x86/intel_rdt: Build structures for each resource based on cache
topology
x86/intel_rdt: Add cpus file
x86/intel_rdt: Add schemata file
Documentation/x86/intel_rdt_ui.txt | 167 +++++
MAINTAINERS | 8 +
arch/x86/include/asm/intel_rdt.h | 145 +++++
arch/x86/kernel/cpu/Makefile | 2 +-
arch/x86/kernel/cpu/intel_rdt.c | 213 ++++++-
arch/x86/kernel/cpu/intel_rdt_rdtgroup.c | 1007 ++++++++++++++++++++++++++++++
arch/x86/kernel/cpu/intel_rdt_schemata.c | 245 ++++++++
arch/x86/kernel/process_32.c | 4 +
arch/x86/kernel/process_64.c | 4 +
include/linux/sched.h | 3 +
include/uapi/linux/magic.h | 1 +
11 files changed, 1797 insertions(+), 2 deletions(-)
create mode 100644 Documentation/x86/intel_rdt_ui.txt
create mode 100644 arch/x86/kernel/cpu/intel_rdt_rdtgroup.c
create mode 100644 arch/x86/kernel/cpu/intel_rdt_schemata.c
--
2.5.0
Powered by blists - more mailing lists