lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 18 Nov 2016 13:29:27 +0530
From:   maitysanchayan@...il.com
To:     Stefan Agner <stefan@...er.ch>
Cc:     broonie@...nel.org, linux-arm-kernel@...ts.infradead.org,
        linux-kernel@...r.kernel.org, linux-spi@...r.kernel.org
Subject: Re: [PATCH 3/4] spi: spi-fsl-dspi: Fix continuous selection format

Hello Stefan,

On 16-11-17 17:07:24, Stefan Agner wrote:
> On 2016-11-17 04:16, Sanchayan Maity wrote:
> > Current DMA implementation was not handling the continuous selection
> > format viz. SPI chip select would be deasserted even between sequential
> > serial transfers. Use the cs_change variable and correctly set or
> > reset the CONT bit accordingly for case where peripherals require
> > the chip select to be asserted between sequential transfers.
> > 
> > Signed-off-by: Sanchayan Maity <maitysanchayan@...il.com>
> > ---
> >  drivers/spi/spi-fsl-dspi.c | 13 ++++++++++---
> >  1 file changed, 10 insertions(+), 3 deletions(-)
> > 
> > diff --git a/drivers/spi/spi-fsl-dspi.c b/drivers/spi/spi-fsl-dspi.c
> > index aee8c88..164e2e1 100644
> > --- a/drivers/spi/spi-fsl-dspi.c
> > +++ b/drivers/spi/spi-fsl-dspi.c
> > @@ -258,9 +258,16 @@ static int dspi_next_xfer_dma_submit(struct fsl_dspi *dspi)
> >  	}
> >  
> >  	val = tx_word ? *(u16 *) dspi->tx : *(u8 *) dspi->tx;
> > -	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > -					SPI_PUSHR_PCS(dspi->cs) |
> > -					SPI_PUSHR_CTAS(0);
> > +	if (dspi->cs_change) {
> > +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > +						SPI_PUSHR_PCS(dspi->cs) |
> > +						SPI_PUSHR_CTAS(0);
> > +	} else {
> > +		dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> > +						SPI_PUSHR_PCS(dspi->cs) |
> > +						SPI_PUSHR_CTAS(0) |
> > +						SPI_PUSHR_CONT;
> > +	}
> 
> How about:
> 
> 
> 	dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) |
> 					SPI_PUSHR_PCS(dspi->cs) |
> 					SPI_PUSHR_CTAS(0);
> 
> +	if (dspi->cs_change)
> +		dspi->dma->tx_dma_buf[i] |= SPI_PUSHR_CONT;
> 
> 
> Avoids code duplication...

Agreed. It's much better. Should be !dspi->cs_change though.

Will include it in next iteration.

Thanks & Regards,
Sanchayan.

> 
> --
> Stefan
> 
> 
> 
> >  	dspi->tx += tx_word + 1;
> >  
> >  	dma->tx_desc = dmaengine_prep_slave_single(dma->chan_tx,

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ