lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 18 Nov 2016 12:41:04 +0100
From:   Greg KH <gregkh@...uxfoundation.org>
To:     Tal Shorer <tal.shorer@...il.com>
Cc:     linux-usb@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2] usb: hcd.h: construct hub class request conastants
 from simpler constants

On Fri, Nov 18, 2016 at 01:18:19PM +0200, Tal Shorer wrote:
> Currently, each hub class request constant is defined by a line like:
> 
> The "magic" number for the high byte is one of 0x20, 0xa0, 0x23, 0xa3.
> The 0x80 bit that changes inditace USB_DIR_IN, and the 0x03 that
> pops up is the difference between USB_RECIP_DEVICE (0x00) and
> USB_RECIP_OTHER (0x03). The constant 0x20 bit is USB_TYPE_CLASS.
> 
> This patch eliminates those magic numbers by defining a macro to help
> construct these hub class request from simpler constants.
> Note that USB_RT_HUB is defined as (USB_TYPE_CLASS | USB_RECIP_DEVICE)
> and that USB_RT_PORT is defined as (USB_TYPE_CLASS | USB_RECIP_OTHER).
> 
> Signed-off-by: Tal Shorer <tal.shorer@...il.com>
> ---
>  include/linux/usb/hcd.h | 19 ++++++++++---------
>  1 file changed, 10 insertions(+), 9 deletions(-)
> 
> diff --git a/include/linux/usb/hcd.h b/include/linux/usb/hcd.h
> index 66fc137..76159fb 100644
> --- a/include/linux/usb/hcd.h
> +++ b/include/linux/usb/hcd.h
> @@ -566,21 +566,22 @@ extern void usb_ep0_reinit(struct usb_device *);
>  	((USB_DIR_OUT|USB_TYPE_STANDARD|USB_RECIP_INTERFACE)<<8)
>  
>  /* class requests from the USB 2.0 hub spec, table 11-15 */
> +#define HUB_CLASS_REQ(dir, type, request) ((((dir) | (type)) << 8) | (request))
>  /* GetBusState and SetHubDescriptor are optional, omitted */
> -#define ClearHubFeature		(0x2000 | USB_REQ_CLEAR_FEATURE)
> -#define ClearPortFeature	(0x2300 | USB_REQ_CLEAR_FEATURE)
> -#define GetHubDescriptor	(0xa000 | USB_REQ_GET_DESCRIPTOR)
> -#define GetHubStatus		(0xa000 | USB_REQ_GET_STATUS)
> -#define GetPortStatus		(0xa300 | USB_REQ_GET_STATUS)
> -#define SetHubFeature		(0x2000 | USB_REQ_SET_FEATURE)
> -#define SetPortFeature		(0x2300 | USB_REQ_SET_FEATURE)
> +#define ClearHubFeature HUB_CLASS_REQ(USB_DIR_OUT, USB_RT_HUB, USB_REQ_CLEAR_FEATURE)

No use of tab?

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ