[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5833FF9E.1030707@bfs.de>
Date: Tue, 22 Nov 2016 09:19:42 +0100
From: walter harms <wharms@....de>
To: Christophe JAILLET <christophe.jaillet@...adoo.fr>
CC: sfrench@...ba.org, linux-cifs@...r.kernel.org,
samba-technical@...ts.samba.org, linux-kernel@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: Re: [PATCH] SMB2: Fix share type handling
Am 21.11.2016 22:53, schrieb Christophe JAILLET:
> In fs/cifs/smb2pdu.h, we have:
> #define SMB2_SHARE_TYPE_DISK 0x01
> #define SMB2_SHARE_TYPE_PIPE 0x02
> #define SMB2_SHARE_TYPE_PRINT 0x03
>
> Knowing that, with the current code, the SMB2_SHARE_TYPE_PRINT case can
> never trigger and printer share would be interpreted as disk share.
>
> So, test the ShareType value for equality instead.
>
> While at it, add some { } to fix a small style issue.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@...adoo.fr>
> ---
> Compile-tested only.
>
> The proposed patch changes a bit the semantic as no masking is performed
> anymore. If some upper bits in 'ShareType' are set, it would now be rejected
> instead of silently accepted.
> ---
> fs/cifs/smb2pdu.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/cifs/smb2pdu.c b/fs/cifs/smb2pdu.c
> index 5ca5ea4668a1..600f52994fd9 100644
> --- a/fs/cifs/smb2pdu.c
> +++ b/fs/cifs/smb2pdu.c
> @@ -1143,12 +1143,12 @@ SMB2_tcon(const unsigned int xid, struct cifs_ses *ses, const char *tree,
> goto tcon_exit;
> }
>
> - if (rsp->ShareType & SMB2_SHARE_TYPE_DISK)
> + if (rsp->ShareType == SMB2_SHARE_TYPE_DISK) {
> cifs_dbg(FYI, "connection to disk share\n");
> - else if (rsp->ShareType & SMB2_SHARE_TYPE_PIPE) {
> + } else if (rsp->ShareType == SMB2_SHARE_TYPE_PIPE) {
> tcon->ipc = true;
> cifs_dbg(FYI, "connection to pipe share\n");
> - } else if (rsp->ShareType & SMB2_SHARE_TYPE_PRINT) {
> + } else if (rsp->ShareType == SMB2_SHARE_TYPE_PRINT) {
> tcon->print = true;
> cifs_dbg(FYI, "connection to printer\n");
> } else {
perhaps a switch/case is better suited for this ?
looks more readable.
re,
wh
switch(sp->ShareType ) {
case SMB2_SHARE_TYPE_DISK:
cifs_dbg(FYI, "connection to disk share\n");
break;
case SMB2_SHARE_TYPE_PIPE:
tcon->ipc = true;
cifs_dbg(FYI, "connection to pipe share\n");
break;
case SMB2_SHARE_TYPE_PRINT:
tcon->ipc = true;
cifs_dbg(FYI, "connection to printer\n");
break;
default:
Powered by blists - more mailing lists