[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20161129060911.GA30454@in.ibm.com>
Date: Tue, 29 Nov 2016 11:39:11 +0530
From: Gautham R Shenoy <ego@...ux.vnet.ibm.com>
To: Michael Ellerman <mpe@...erman.id.au>
Cc: "Gautham R. Shenoy" <ego@...ux.vnet.ibm.com>,
Benjamin Herrenschmidt <benh@...nel.crashing.org>,
Paul Mackerras <paulus@...ba.org>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
Daniel Lezcano <daniel.lezcano@...aro.org>,
Michael Neuling <mikey@...ling.org>,
Vaidyanathan Srinivasan <svaidy@...ux.vnet.ibm.com>,
"Shreyas B. Prabhu" <shreyasbp@...il.com>,
Shilpasri G Bhat <shilpa.bhat@...ux.vnet.ibm.com>,
Stewart Smith <stewart@...ux.vnet.ibm.com>,
Balbir Singh <bsingharora@...il.com>,
"Oliver O'Halloran" <oohall@...il.com>,
linuxppc-dev@...ts.ozlabs.org, linux-kernel@...r.kernel.org,
linux-pm@...r.kernel.org, skiboot@...ts.ozlabs.org
Subject: Re: [PATCH v3 2/3] cpuidle:powernv: Add helper function to populate
powernv idle states.
Hi Michael,
On Wed, Nov 23, 2016 at 08:49:08PM +1100, Michael Ellerman wrote:
> "Gautham R. Shenoy" <ego@...ux.vnet.ibm.com> writes:
>
> > diff --git a/drivers/cpuidle/cpuidle-powernv.c b/drivers/cpuidle/cpuidle-powernv.c
> > index 7fe442c..9240e08 100644
> > --- a/drivers/cpuidle/cpuidle-powernv.c
> > +++ b/drivers/cpuidle/cpuidle-powernv.c
> > @@ -243,28 +262,31 @@ static int powernv_add_idle_states(void)
> > */
> > if (latency_ns[i] > POWERNV_THRESHOLD_LATENCY_NS)
> > continue;
> > + /*
> > + * Firmware passes residency and latency values in ns.
> > + * cpuidle expects it in us.
> > + */
> > + exit_latency = ((unsigned int)latency_ns[i]) / 1000;
> > + target_residency = (!rc) ? ((unsigned int)residency_ns[i]) : 0;
> > + target_residency /= 1000;
>
> Urk.
>
> Can you just do it normally:
>
> if (rc == 0)
> target_residency = (unsigned int)residency_ns[i] / 1000;
Wrote this in a non-standard manner since the normal way would exceed
80 chars.
>
> I also don't see why you need the cast?
It is a remnant from the previous code. But I see your point, the cast
is redundant, and removing it will make it possible to implement this
in the normal manner without checkpatch warning about it.
>
> cheers
>
--
Thanks and Regards
gautham.
Powered by blists - more mailing lists