lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Mon, 12 Dec 2016 11:24:56 +0100
From:   Rafał Miłecki <zajec5@...il.com>
To:     Arend van Spriel <arend.vanspriel@...adcom.com>
Cc:     Ming Lei <ming.lei@...onical.com>,
        "Luis R . Rodriguez" <mcgrof@...nel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Rafał Miłecki <rafal@...ecki.pl>
Subject: Re: [PATCH V2] firmware: simplify defining and handling FW_OPT_FALLBACK

On 11 December 2016 at 23:46, Arend van Spriel
<arend.vanspriel@...adcom.com> wrote:
> On 11-12-16 22:21, Rafał Miłecki wrote:
>> From: Rafał Miłecki <rafal@...ecki.pl>
>>
>> I found handling of FW_OPT_FALLBACK a bit complex. It was defined using
>> another option and their values were dependent on kernel config.
>>
>> It was also non-trivial to follow the code. Some callers were using
>> FW_OPT_FALLBACK which was confusing since the _request_firmware function
>> was always checking for FW_OPT_USERHELPER (the same bit in a relevant
>> configuration).
>>
>> With this patch FW_OPT_USERHELPER gets its own bit and is explicitly
>> checked in the _request_firmware which hopefully makes code easier to
>> understand.
>>
>> Signed-off-by: Rafał Miłecki <rafal@...ecki.pl>
>> ---
>> V2: s/config_enabled/IS_ENABLED/ to compile since c0a0aba8e47 ("kconfig.h: remove config_enabled() macro")
>> ---
>>  drivers/base/firmware_class.c | 12 ++++++------
>>  1 file changed, 6 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
>> index 22d1760..0e1d5b8 100644
>> --- a/drivers/base/firmware_class.c
>> +++ b/drivers/base/firmware_class.c
>> @@ -112,13 +112,9 @@ static inline long firmware_loading_timeout(void)
>>  #else
>>  #define FW_OPT_USERHELPER    0
>>  #endif
>> -#ifdef CONFIG_FW_LOADER_USER_HELPER_FALLBACK
>> -#define FW_OPT_FALLBACK              FW_OPT_USERHELPER
>> -#else
>> -#define FW_OPT_FALLBACK              0
>> -#endif
>>  #define FW_OPT_NO_WARN       (1U << 3)
>>  #define FW_OPT_NOCACHE       (1U << 4)
>> +#define FW_OPT_FALLBACK      (1U << 5)
>>
>>  struct firmware_cache {
>>       /* firmware_buf instance will be added into the below list */
>> @@ -1175,8 +1171,12 @@ _request_firmware(const struct firmware **firmware_p, const char *name,
>>                       dev_warn(device,
>>                                "Direct firmware load for %s failed with error %d\n",
>>                                name, ret);
>> -             if (opt_flags & FW_OPT_USERHELPER) {
>> +             if (IS_ENABLED(CONFIG_FW_LOADER_USER_HELPER_FALLBACK) &&
>> +                 opt_flags & FW_OPT_FALLBACK) {
>
> When mixing logical and binary expressions I would suggest putting the
> binary expression between brackets.

I checked my patch with checkpatch.pl before sending and it didn't
complain. I just re-read CodingStyle but I didn't find any info on
this.

It this some upstream-documented preference for coding style?

-- 
Rafał

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ