[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170109180051.uwd4su3maj5gkf5l@rob-hp-laptop>
Date: Mon, 9 Jan 2017 12:00:51 -0600
From: Rob Herring <robh@...nel.org>
To: Benjamin Gaignard <benjamin.gaignard@...aro.org>
Cc: lee.jones@...aro.org, mark.rutland@....com,
alexandre.torgue@...com, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, thierry.reding@...il.com,
linux-pwm@...r.kernel.org, jic23@...nel.org, knaack.h@....de,
lars@...afoo.de, pmeerw@...erw.net, linux-iio@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, fabrice.gasnier@...com,
gerald.baeza@...com, arnaud.pouliquen@...com,
linus.walleij@...aro.org, linaro-kernel@...ts.linaro.org,
Benjamin Gaignard <benjamin.gaignard@...com>
Subject: Re: [PATCH v7 2/8] MFD: add STM32 Timers driver
On Thu, Jan 05, 2017 at 10:25:38AM +0100, Benjamin Gaignard wrote:
> This hardware block could at used at same time for PWM generation
> and IIO timers.
> PWM and IIO timer configuration are mixed in the same registers
> so we need a multi fonction driver to be able to share those registers.
>
> version 7:
> - rebase on v4.10-rc2
>
> version 6:
> - rename files to stm32-timers
> - rename functions to stm32_timers_xxx
>
> version 5:
> - fix Lee comments about detect function
> - add missing dependency on REGMAP_MMIO
>
> version 4:
> - add a function to detect Auto Reload Register (ARR) size
> - rename the structure shared with other drivers
>
> version 2:
> - rename driver "stm32-gptimer" to be align with SoC documentation
> - only keep one compatible
> - use of_platform_populate() instead of devm_mfd_add_devices()
>
> Signed-off-by: Benjamin Gaignard <benjamin.gaignard@...com>
> ---
> .../devicetree/bindings/mfd/stm32-timers.txt | 2 +-
> drivers/mfd/Kconfig | 11 +++
> drivers/mfd/Makefile | 2 +
> drivers/mfd/stm32-timers.c | 80 ++++++++++++++++++++++
> include/linux/mfd/stm32-timers.h | 71 +++++++++++++++++++
> 5 files changed, 165 insertions(+), 1 deletion(-)
> create mode 100644 drivers/mfd/stm32-timers.c
> create mode 100644 include/linux/mfd/stm32-timers.h
>
> diff --git a/Documentation/devicetree/bindings/mfd/stm32-timers.txt b/Documentation/devicetree/bindings/mfd/stm32-timers.txt
> index a73301d..897e7c2 100644
> --- a/Documentation/devicetree/bindings/mfd/stm32-timers.txt
> +++ b/Documentation/devicetree/bindings/mfd/stm32-timers.txt
> @@ -12,7 +12,7 @@ Required parameters:
>
> - reg: Physical base address and length of the controller's
> registers.
> -- clock-names: Set to "int".
> +- clock-names: Set to "int".
This hunk should be dropped or moved to previous patch.
> - clocks: Phandle to the clock used by the timer module.
> For Clk properties, please refer to ../clock/clock-bindings.txt
>
Powered by blists - more mailing lists