[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1484148146-14210-1-git-send-email-dave@stgolabs.net>
Date: Wed, 11 Jan 2017 07:22:24 -0800
From: Davidlohr Bueso <dave@...olabs.net>
To: mingo@...nel.org, peterz@...radead.org
Cc: oleg@...hat.com, dave@...olabs.net, linux-kernel@...r.kernel.org
Subject: [PATCH v2 0/2] sched: Introduce rcuwait
Changes from v1:
- Renamed trywake to wake_up.
- Added Oleg's review tags.
Hi,
Here's an updated version of the pcpu rwsem writer wait/wake changes
with the abstractions wanted by Oleg. Patch 1 adds rcuwait (for a lack
of better name), and patch 2 trivially makes use of it.
Has survived torture testing, which is actually very handy in this case
particularly dealing with equal amount of reader and writer threads.
Applies on top of Linus' tree (4.10-rc3).
Thanks.
Davidlohr Bueso (2):
sched: Introduce rcuwait machinery
locking/percpu-rwsem: Replace waitqueue with rcuwait
include/linux/percpu-rwsem.h | 8 +++---
include/linux/rcuwait.h | 63 +++++++++++++++++++++++++++++++++++++++++++
kernel/exit.c | 30 +++++++++++++++++++++
kernel/locking/percpu-rwsem.c | 7 +++--
4 files changed, 100 insertions(+), 8 deletions(-)
create mode 100644 include/linux/rcuwait.h
--
2.6.6
Powered by blists - more mailing lists