[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170112153315.GC13843@arm.com>
Date: Thu, 12 Jan 2017 15:33:15 +0000
From: Will Deacon <will.deacon@....com>
To: Robert Richter <rrichter@...ium.com>
Cc: Catalin Marinas <catalin.marinas@....com>,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] arm64: errata: Provide macro for major and minor cpu
revisions
On Wed, Jan 11, 2017 at 01:11:42PM +0100, Robert Richter wrote:
> Definition of cpu ranges are hard to read if the cpu variant is not
> zero. Provide MIDR_CPU_FULL_REV() macro to describe the full hardware
> revision of a cpu including variant and (minor) revision.
>
> Signed-off-by: Robert Richter <rrichter@...ium.com>
> ---
> arch/arm64/include/asm/cputype.h | 3 +++
> arch/arm64/kernel/cpu_errata.c | 15 +++++++++------
> arch/arm64/kernel/cpufeature.c | 8 +++-----
> 3 files changed, 15 insertions(+), 11 deletions(-)
>
> diff --git a/arch/arm64/include/asm/cputype.h b/arch/arm64/include/asm/cputype.h
> index 26a68ddb11c1..983e59cbdd54 100644
> --- a/arch/arm64/include/asm/cputype.h
> +++ b/arch/arm64/include/asm/cputype.h
> @@ -56,6 +56,9 @@
> (0xf << MIDR_ARCHITECTURE_SHIFT) | \
> ((partnum) << MIDR_PARTNUM_SHIFT))
>
> +#define MIDR_CPU_FULL_REV(var, rev) \
> + (((var) << MIDR_VARIANT_SHIFT) | (rev))
Minor nit, but could you rename this to MIDR_CPU_VAR_REV instead please?
The revision field *is* the bottom 4 bits, so "full" rev doesn't really
make a lot of sense.
If you repost with that change, I'll pick it up for 4.11.
Thanks,
Will
Powered by blists - more mailing lists