lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 16 Jan 2017 15:58:26 +0100
From:   "Maciej S. Szmigiero" <>
To:     Jarkko Sakkinen <>
        linux-kernel <>,
        Peter Huewe <>,
        Marcel Selhorst <>,
        Christophe Ricard <>,
        Jason Gunthorpe <>
Subject: Re: [PATCH] tpm_tis: use default timeout value if chip reports it as

On 16.01.2017 14:55, Jarkko Sakkinen wrote:
> On Mon, Jan 16, 2017 at 03:46:12PM +0200, Jarkko Sakkinen wrote:
>> On Mon, Jan 16, 2017 at 11:42:02AM +0200, Jarkko Sakkinen wrote:
>>> On Fri, Jan 13, 2017 at 10:37:00PM +0100, Maciej S. Szmigiero wrote:
>>>> Since commit 1107d065fdf1 ("tpm_tis: Introduce intermediate layer for TPM
>>>> access") Atmel 3203 TPM on ThinkPad X61S (TPM firmware version 13.9) no
>>>> longer works.
>>>> The initialization proceeds fine until we get and start using chip-reported
>>>> timeouts - and the chip reports C and D timeouts of zero.
>>>> It turns out that until commit 8e54caf407b98e ("tpm: Provide a generic
>>>> means to override the chip returned timeouts") we had actually let default
>>>> timeout values remain in this case, so let's bring back this behavior to
>>>> make chips like Atmel 3203 work again.
>>>> Use a common code that was introduced by that commit so a warning is
>>>> printed in this case and /sys/class/tpm/tpm*/timeouts correctly says the
>>>> timeouts aren't chip-original.
>>>> Signed-off-by: Maciej S. Szmigiero <>
>>>> Fixes: 1107d065fdf1 ("tpm_tis: Introduce intermediate layer for TPM access")
>>>> Cc:
>>> Reviewed-by: Jarkko Sakkinen <>
>> It's now applied to my master branch so if someone wants to
>> test it, it should be fairly easy.
> And I decided to squash the rename commit to it.

Wouldn't it be better to squash the rename commit into "fix iTPM probe via
probe_itpm() function" patch (if it isn't too late), since they touch the
same functionality?

> /Jarkko


Powered by blists - more mailing lists