lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 21 Jan 2017 10:06:00 -0500
From:   Zhihui Zhang <>
To:     John Stultz <>
Cc:     Thomas Gleixner <>,
        lkml <>
Subject: Re: [PATCH] timers: Reconcile the code and the comment for the 250HZ case

Sure, I believe that comments should always match the code. In this
case, using either LVL_SIZE - 1 or LVL_SIZE is fine based on my
understanding about 20 days ago. But I could be wrong and miss some
subtle details. Anyway, my point is about readability.


On Fri, Jan 20, 2017 at 5:41 PM, John Stultz <> wrote:
> On Mon, Jan 2, 2017 at 1:14 PM, Zhihui Zhang <> wrote:
>> Adjust the time start of each level to match the comments. Note that
>> LVL_START(n) is never used for n = 0 case.  Also, each level (except
>> level 0) has more than enough room to accommodate all its timers.
> So instead of just covering what your patch does, can you explain in
> some detail why this patch is useful? What net effect does it bring?
> What sort of bugs would it solve?
> thanks
> -john

Powered by blists - more mailing lists