lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 25 Jan 2017 12:21:05 +0100
From:   Laura Abbott <>
To:     Pavel Machek <>
Cc:     Kees Cook <>,
        Jason Wessel <>,
        Jonathan Corbet <>,
        Russell King <>,
        Catalin Marinas <>,
        Will Deacon <>,
        "James E.J. Bottomley" <>,
        Helge Deller <>,
        Martin Schwidefsky <>,
        Heiko Carstens <>,
        Thomas Gleixner <>,
        Ingo Molnar <>,
        "H. Peter Anvin" <>,,
        Rob Herring <>,
        "Rafael J. Wysocki" <>,
        Len Brown <>,
        Mark Rutland <>,
        Jessica Yu <>,,,,,,,
Subject: Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA

On 01/19/2017 08:53 AM, Pavel Machek wrote:
> On Wed 2017-01-18 17:29:05, Laura Abbott wrote:
>> Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option
>> provides key security features that are to be expected on a modern
>> system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more
>> accurately describes what this option is intended to do.
> I think this is bad change. CONFIG_DEBUG_RODATA is describing what it
> does, CONFIG_HARDENED_PAGE_MAPPINGS is advertising.
> We don't do advertising, and we don't force people to re-answer the
> config questions without good reason.
> CONFIG_HARDENED_RODATA might fix the first problem, but not the second
> one.
> 								Pavel

(Apologies, my SMTP was set up incorrectly so my response didn't
actually get sent out)

CONFIG_DEBUG_RODATA isn't describing what it does though. It misses
that this config may handle much more than just rodata. I think
Mark Rutland's suggestion of STRICT_KERNEL_RWX might be more


Powered by blists - more mailing lists