[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1485426179-13681-1-git-send-email-mingo@kernel.org>
Date: Thu, 26 Jan 2017 11:22:45 +0100
From: Ingo Molnar <mingo@...nel.org>
To: linux-kernel@...r.kernel.org
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Andy Lutomirski <luto@...capital.net>,
Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>,
Fenghua Yu <fenghua.yu@...el.com>,
"H . Peter Anvin" <hpa@...or.com>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Oleg Nesterov <oleg@...hat.com>,
Peter Zijlstra <peterz@...radead.org>,
Rik van Riel <riel@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>,
Yu-cheng Yu <yu-cheng.yu@...el.com>
Subject: [PATCH 00/14] x86/fpu: Clean up ptrace copying functions
This series deobfuscates the ptrace/regset handling functions of the x86 FPU
code. As a side effect it (should ...) fix the bug Rik reported in:
[PATCH 1/2] x86/fpu: move copyout_from_xsaves bounds check before the copy
but it does not handle the other fix yet:
[PATCH 2/2] x86/fpu: copy MXCSR & MXCSR_FLAGS with SSE/YMM state
... which needs to be rebased on top of this series.
The code got larger, but it is now a lot more standard and a lot easier to
understand as well.
Only very minimally tested: we should also add various ptrace XSAVES testcases
to tools/testing/selftests/x86/.
Obviously this will have to be backported as a single group of commits - but I'd rather
do that than leave the mess around.
Ingo Molnar (14):
x86/fpu: Rename copyin_to_xsaves()/copyout_from_xsaves() to copy_user_to_xstate()/copy_xstate_to_user()
x86/fpu: Split copy_xstate_to_user() into copy_xstate_to_kernel() & copy_xstate_to_user()
x86/fpu: Remove 'ubuf' parameter from the copy_xstate_to_kernel() APIs
x86/fpu: Remove 'kbuf' parameter from the copy_xstate_to_user() APIs
x86/fpu: Clean up parameter order in the copy_xstate_to_*() APIs
x86/fpu: Clean up the parameter definitions of copy_xstate_to_*()
x86/fpu: Remove the 'start_pos' parameter from the __copy_xstate_to_*() functions
x86/fpu: Clarify parameter names in the copy_xstate_to_*() methods
x86/fpu: Change 'size_total' parameter to unsigned and standardize the size checks in copy_xstate_to_*()
x86/fpu: Simplify __copy_xstate_to_kernel() return values
x86/fpu: Split copy_user_to_xstate() into copy_kernel_to_xstate() & copy_user_to_xstate()
x86/fpu: Remove 'ubuf' parameter from the copy_kernel_to_xstate() API
x86/fpu: Remove 'kbuf' parameter from the copy_user_to_xstate() API
x86/fpu: Flip the parameter order in copy_*_to_xstate()
arch/x86/include/asm/fpu/xstate.h | 8 +--
arch/x86/kernel/fpu/regset.c | 15 +++--
arch/x86/kernel/fpu/signal.c | 11 ++--
arch/x86/kernel/fpu/xstate.c | 188 ++++++++++++++++++++++++++++++++++++++++++++++------------
4 files changed, 168 insertions(+), 54 deletions(-)
--
2.7.4
Powered by blists - more mailing lists