[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170127122930.GL4149@mwanda>
Date: Fri, 27 Jan 2017 15:29:30 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: mrossibellom@...il.com
Cc: johan@...nel.org, elder@...nel.org, gregkh@...uxfoundation.org,
greybus-dev@...ts.linaro.org, devel@...verdev.osuosl.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] greybus: Fix coding stye error
On Fri, Jan 27, 2017 at 11:11:21AM +0100, mrossibellom@...il.com wrote:
> From: Maxime Rossi Bellom <mrossibellom@...il.com>
>
> Split line before funtion argument.
>
> Error was reported by checkpatch.pl as
> WARNING: line over 80 characters
>
> Signed-off-by: Maxime Rossi Bellom <mrossibellom@...il.com>
> ---
> drivers/staging/greybus/fw-management.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/greybus/fw-management.c b/drivers/staging/greybus/fw-management.c
> index 3cd6cf0..d88117e 100644
> --- a/drivers/staging/greybus/fw-management.c
> +++ b/drivers/staging/greybus/fw-management.c
> @@ -516,7 +516,8 @@ static int fw_mgmt_ioctl(struct fw_mgmt *fw_mgmt, unsigned int cmd,
> */
> fw_mgmt->mode_switch_started = true;
>
> - ret = gb_interface_request_mode_switch(fw_mgmt->connection->intf);
> + ret = gb_interface_request_mode_switch(
> + fw_mgmt->connection->intf);
Another option would be to change the name from
gb_interface_request_mode_switch() to gb_get_mode_switch() or something
along those lines. It requires understanding the code to say what a
good name is.
regards,
dan carpenter
Powered by blists - more mailing lists