[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170130214657.GB31134@builder>
Date: Mon, 30 Jan 2017 13:46:57 -0800
From: Bjorn Andersson <bjorn.andersson@...aro.org>
To: Avaneesh Kumar Dwivedi <akdwived@...eaurora.org>
Cc: sboyd@...eaurora.org, agross@...eaurora.org,
linux-arm-msm@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-remoteproc@...r.kernel.org
Subject: Re: [PATCH v3 2/4] remoteproc: qcom: Add additional agree2_clk and
px regulator resource.
On Mon 30 Jan 07:03 PST 2017, Avaneesh Kumar Dwivedi wrote:
> This patch add additional clock and regulator resource which are
> initialized based on compatible and has no impact on existing driver
> working. This resourse addition enable the existing driver to handle.
> low pass sensor processor device also.
>
> Signed-off-by: Avaneesh Kumar Dwivedi <akdwived@...eaurora.org>
Applied, with below modification.
> ---
> drivers/remoteproc/qcom_adsp_pil.c | 43 +++++++++++++++++++++++++++++++-------
> 1 file changed, 36 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/remoteproc/qcom_adsp_pil.c b/drivers/remoteproc/qcom_adsp_pil.c
[..]
> static int adsp_init_regulator(struct qcom_adsp *adsp)
> {
> - adsp->cx_supply = devm_regulator_get(adsp->dev, "cx");
> + adsp->cx_supply = devm_regulator_get(adsp->dev, "vdd_cx");
We should not change the name of devicetree properties, so I dropped
"vdd_" on both of these.
> if (IS_ERR(adsp->cx_supply))
> return PTR_ERR(adsp->cx_supply);
>
> regulator_set_load(adsp->cx_supply, 100000);
>
> + adsp->px_supply = devm_regulator_get(adsp->dev, "vdd_px");
> + if (IS_ERR(adsp->px_supply))
> + return PTR_ERR(adsp->px_supply);
Regards,
Bjorn
Powered by blists - more mailing lists