[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170206145238.GI2267@bombadil.infradead.org>
Date: Mon, 6 Feb 2017 06:52:38 -0800
From: Matthew Wilcox <willy@...radead.org>
To: Vlastimil Babka <vbabka@...e.cz>
Cc: Andrew Morton <akpm@...ux-foundation.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, Joonsoo Kim <iamjoonsoo.kim@....com>,
David Rientjes <rientjes@...gle.com>,
Pekka Enberg <penberg@...nel.org>,
Christoph Lameter <cl@...ux.com>
Subject: Re: [PATCH] mm, slab: rename kmalloc-node cache to kmalloc-<size>
On Fri, Feb 03, 2017 at 07:10:08PM +0100, Vlastimil Babka wrote:
> diff --git a/mm/slab.c b/mm/slab.c
> index a95fd4fed0a8..ede31b59bb9f 100644
> --- a/mm/slab.c
> +++ b/mm/slab.c
> @@ -1293,7 +1293,8 @@ void __init kmem_cache_init(void)
> * Initialize the caches that provide memory for the kmem_cache_node
> * structures first. Without this, further allocations will bug.
> */
> - kmalloc_caches[INDEX_NODE] = create_kmalloc_cache("kmalloc-node",
> + kmalloc_caches[INDEX_NODE] = create_kmalloc_cache(
> + get_kmalloc_cache_name(INDEX_NODE),
Could we lose the 'get_' from the front? I think 'kmalloc_cache_name()' is
just as informative.
Reviewed-by: Matthew Wilcox <mawilcox@...rosoft.com>
Powered by blists - more mailing lists