[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170214095725.GD15721@lahna.fi.intel.com>
Date: Tue, 14 Feb 2017 11:57:25 +0200
From: Mika Westerberg <mika.westerberg@...ux.intel.com>
To: Marek Vasut <marek.vasut@...il.com>
Cc: Nicholas Mc Guire <der.herr@...r.at>,
Cyrille Pitchen <cyrille.pitchen@...el.com>,
David Woodhouse <dwmw2@...radead.org>,
Brian Norris <computersforpeace@...il.com>,
Boris Brezillon <boris.brezillon@...e-electrons.com>,
Richard Weinberger <richard@....at>,
linux-mtd@...ts.infradead.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH V2] mtd: spi-nor: intel: use true/false for boolean
On Tue, Feb 14, 2017 at 05:52:48AM +0100, Marek Vasut wrote:
> On 02/13/2017 09:13 AM, Nicholas Mc Guire wrote:
> > writeable in struct intel_spi is a boolean and assignment should be to
> > true/false not 1/0 as recommended by boolinit.cocci.
> >
> > Signed-off-by: Nicholas Mc Guire <der.herr@...r.at>
> > ---
> >
> > make coccicheck complained with:
> > ./drivers/mtd/spi-nor/intel-spi.c:707:3-18: WARNING: Assignment of bool to 0/1
> >
> > Patch was compile tested with: multi_v7_defconfig (implies CONFIG_MTD_SPI_NOR=y)
> >
> > Patch is against 4.10-rc7 (localversion-next is next-20170213)
> >
> > drivers/mtd/spi-nor/intel-spi.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/mtd/spi-nor/intel-spi.c b/drivers/mtd/spi-nor/intel-spi.c
> > index 4630716..2956f2c 100644
> > --- a/drivers/mtd/spi-nor/intel-spi.c
> > +++ b/drivers/mtd/spi-nor/intel-spi.c
> > @@ -704,7 +704,7 @@ static void intel_spi_fill_partition(struct intel_spi *ispi,
> > * whole partition read-only to be on the safe side.
> > */
> > if (intel_spi_is_protected(ispi, base, limit))
> > - ispi->writeable = 0;
> > + ispi->writeable = false;
> >
> > end = (limit << 12) + 4096;
> > if (end > part->size)
> >
>
> Looks OK, also this is the only place in the driver where writeable is
> assigned to an explicit true/false value.
>
> Acked-by: Marek Vasut <marek.vasut@...il.com>
Also
Acked-by: Mika Westerberg <mika.westerberg@...ux.intel.com>
> btw the variable should be renamed from writeable to writable ;-)
It is named like that because it follows MTD_WRITEABLE flag.
Powered by blists - more mailing lists