[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <tip-5d4bac9a5f4ef24b2482529bda6661a58e5b5b65@git.kernel.org>
Date: Thu, 16 Feb 2017 06:34:42 -0800
From: tip-bot for Jeremy Kerr <tipbot@...or.com>
To: linux-tip-commits@...r.kernel.org
Cc: jk@...abs.org, tglx@...utronix.de, mingo@...nel.org, hpa@...or.com,
linux-kernel@...r.kernel.org
Subject: [tip:irq/core] genirq: Clarify logic calculating bogus irqreturn_t
values
Commit-ID: 5d4bac9a5f4ef24b2482529bda6661a58e5b5b65
Gitweb: http://git.kernel.org/tip/5d4bac9a5f4ef24b2482529bda6661a58e5b5b65
Author: Jeremy Kerr <jk@...abs.org>
AuthorDate: Thu, 16 Feb 2017 12:24:09 +0800
Committer: Thomas Gleixner <tglx@...utronix.de>
CommitDate: Thu, 16 Feb 2017 15:32:19 +0100
genirq: Clarify logic calculating bogus irqreturn_t values
Although irqreturn_t is an enum, we treat it (and its enumeration
constants) as a bitmask.
However, bad_action_ret() uses a less-than operator to determine whether
an irqreturn_t falls within allowable bit values, which means we need to
know the signededness of an enum type to read the logic, which is
implementation-dependent.
This change explicitly uses an unsigned type for the comparison. We do
this instead of changing to a bitwise test, as the latter compiles to
increased instructions in this hot path.
It looks like we get the correct behaviour currently (bad_action_ret(-1)
returns 1), so this is purely a readability fix.
Signed-off-by: Jeremy Kerr <jk@...abs.org>
Link: http://lkml.kernel.org/r/1487219049-4061-1-git-send-email-jk@ozlabs.org
Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
---
kernel/irq/spurious.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/kernel/irq/spurious.c b/kernel/irq/spurious.c
index 5707f97..061ba7e 100644
--- a/kernel/irq/spurious.c
+++ b/kernel/irq/spurious.c
@@ -175,7 +175,9 @@ out:
static inline int bad_action_ret(irqreturn_t action_ret)
{
- if (likely(action_ret <= (IRQ_HANDLED | IRQ_WAKE_THREAD)))
+ unsigned int r = action_ret;
+
+ if (likely(r <= (IRQ_HANDLED | IRQ_WAKE_THREAD)))
return 0;
return 1;
}
Powered by blists - more mailing lists