lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Fri, 17 Feb 2017 09:45:11 +0800
From:   Fengguang Wu <>
To:     Kalle Valo <>
Cc:     Arend Van Spriel <>,
        Randy Dunlap <>,,,,
        Rafał Miłecki <>
Subject: Re: [kbuild-all]
 drivers/net/wireless/broadcom/brcm80211/brcmfmac/debug.c:58:6: error:
 redefinition of 'brcmf_debugfs_init'

Hi Kalle,

On Thu, Feb 16, 2017 at 03:18:48PM +0200, Kalle Valo wrote:
>Arend Van Spriel <> writes:
>> On 16-2-2017 11:01, Kalle Valo wrote:
>>> Arend Van Spriel <> writes:
>>>> On 16-2-2017 10:39, Rafał Miłecki wrote:
>>>>> On 02/16/2017 10:31 AM, Kalle Valo wrote:
>>>>>> (Adding linux-wireless)
>>>>>> Arend or Rafał, would you be able to look at this build problem? Kbuild
>>>>>> found the build errors below, apparently a very old issue. It just
>>>>>> blames me now because I moved the driver to a new directory :)
>>>> It is a very old issue. The thing is that the issue can not really occur
>>>> because we have this:
>>>> # common flags
>>>> subdir-ccflags-$(CONFIG_BRCMDBG)        += -DDEBUG
>>>> in drivers/net/wireless/broadcom/brcm80211/Makefile. So no clue what
>>>> happens in the "kbuild test robot" scenario.
>>> I actually tried to reproduce this with kbuild bot's instructions and
>>> was surprised to see that the build worked ok for me. So the issue is
>>> not that simple.
>> Hi Kalle,
>> Here is the old email exchange we had about this [1]. In my opinion this
>> is a Kbuild issue that needs to be looked into.
>> Regards,
>> Arend
>> [1]
>Heh, I had completely forgotten that we had discussed this before :)
>Fengguang and the kbuild bot team, do you have any ideas why only the
>bot is seeing this?

I guess the root cause is due to the robot's doing partial builds like

        make drivers/net/wireless/broadcom/brcm80211/brcmfmac/debug.o
        make drivers/net/wireless/broadcom/brcm80211/brcmfmac/

The solution I come about is to climb up to higher level dirs like 

        make drivers/net/wireless/

which is less likely to have Makefile tricks and still maintain fast
enough build tests.


Powered by blists - more mailing lists