lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Fri, 17 Feb 2017 11:22:02 -0500 From: Johannes Weiner <hannes@...xchg.org> To: Shaohua Li <shli@...com> Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org, Kernel-team@...com, mhocko@...e.com, minchan@...nel.org, hughd@...gle.com, riel@...hat.com, mgorman@...hsingularity.net, akpm@...ux-foundation.org Subject: Re: [PATCH V3 2/7] mm: move MADV_FREE pages into LRU_INACTIVE_FILE list On Thu, Feb 16, 2017 at 04:35:25PM -0800, Shaohua Li wrote: > On Thu, Feb 16, 2017 at 12:52:53PM -0500, Johannes Weiner wrote: > > On Tue, Feb 14, 2017 at 11:36:08AM -0800, Shaohua Li wrote: > > > @@ -126,4 +126,24 @@ static __always_inline enum lru_list page_lru(struct page *page) > > > > > > #define lru_to_page(head) (list_entry((head)->prev, struct page, lru)) > > > > > > +/* > > > + * lazyfree pages are clean anonymous pages. They have SwapBacked flag cleared > > > + * to destinguish normal anonymous pages. > > > + */ > > > +static inline void set_page_lazyfree(struct page *page) > > > +{ > > > + VM_BUG_ON_PAGE(!PageAnon(page) || !PageSwapBacked(page), page); > > > + ClearPageSwapBacked(page); > > > +} > > > + > > > +static inline void clear_page_lazyfree(struct page *page) > > > +{ > > > + VM_BUG_ON_PAGE(!PageAnon(page) || PageSwapBacked(page), page); > > > + SetPageSwapBacked(page); > > > +} > > > + > > > +static inline bool page_is_lazyfree(struct page *page) > > > +{ > > > + return PageAnon(page) && !PageSwapBacked(page); > > > +} > > > > Sorry for not getting to v2 in time, but I have to say I strongly > > agree with your first iterations and would much prefer this to be > > open-coded. > > > > IMO this needlessly introduces a new state opaquely called "lazyfree", > > when really that's just anonymous pages that don't need to be swapped > > before reclaim - PageAnon && !PageSwapBacked. Very simple MM concept. > > > > That especially shows when we later combine it with page_is_file_cache > > checks like the next patch does. > > > > The rest of the patch looks good to me. > > Thanks! I do agree checking PageSwapBacked is clearer, but Minchan convinced me > because of the accounting issue. Where do you suggest we should put the > accounting to? I now proposed quite a few changes to the setting and clearing sites, so it's harder to judge, but AFAICT once those sites are consolidated, open-coding the stat updates as well shouldn't be too bad, right? One site to clear during MADV_FREE, one site to set during reclaim.
Powered by blists - more mailing lists