lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 20 Feb 2017 12:19:24 -0700
From:   Jim Davis <jim.epost@...il.com>
To:     linux-doc <linux-doc@...r.kernel.org>,
        linux-kernel <linux-kernel@...r.kernel.org>,
        Jonathan Corbet <corbet@....net>
Subject: making documentation targets on v4.10 with Fedora 25

I ran a script like the one below to make the various Sphinx and
DocBook documentations targets for v4.10 on my Fedora 25 desktop

make O=/tmp/sphinx-out DOCBOOKS="" htmldocs
make O=/tmp/sphinx-out DOCBOOKS="" latexdocs
make O=/tmp/sphinx-out DOCBOOKS="" pdfdocs
make O=/tmp/sphinx-out DOCBOOKS="" epubdocs
make O=/tmp/sphinx-out DOCBOOKS="" xmldocs
make O=/tmp/sphinx-out DOCBOOKS="" cleandocs

make O=/tmp/docbook-out SPHINXBUILD=/none/such htmldocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such pdfdocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such psdocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such xmldocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such mandocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such installmandocs
make O=/tmp/docbook-out SPHINXBUILD=/none/such cleandocs

with mixed results.

For the Sphinx targets, htmldocs, pdfdocs, epubdocs, and cleandocs
failed.  cleandocs works without the O= argument, and arguably the O=
thing isn't very useful with any of these targets, but it is supported
by the top-level Makefile.

For the DocBook targets, pdfdocs and psdocs failed.

pdfdocs (Sphinx or DocBook) has been broken for some time, while
psdocs hasn't worked in ages.  The errors with the Sphinx htmldocs and
epubdocs targets seem to be some Python issue:

Exception occurred:
  File "/usr/lib/python3.5/site-packages/docutils/writers/_html_base.py", line
671, in depart_document
    assert not self.context, 'len(context) = %s' % len(self.context)
AssertionError: len(context) = 1
The full traceback has been saved in /tmp/sphinx-err-o52yw6s4.log, if you want
to report the issue to the developers.
Please also report this if it was a user error, so that a better error message
can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphi
nx/issues>. Thanks!
make[2]: *** [epubdocs] Error 1
make[1]: *** [epubdocs] Error 2
make: *** [sub-make] Error 2

and similarly for htmldocs.

-- 
Jim

Powered by blists - more mailing lists