lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 7 Mar 2017 14:06:16 +0100
From:   Steffen Maier <maier@...ux.vnet.ibm.com>
To:     Jiri Slaby <jslaby@...e.cz>
Cc:     linux-kernel@...r.kernel.org,
        Lukáš Korenčik <xkorenc1@...muni.cz>,
        Martin Schwidefsky <schwidefsky@...ibm.com>,
        Heiko Carstens <heiko.carstens@...ibm.com>,
        linux-s390@...r.kernel.org
Subject: Re: [PATCH] s390: scsi, use setup_timer instead of init_timer

Thanks, Lukáš, Jiri, queued for next zfcp feature submission to 
linux-scsi as:

"zfcp: use setup_timer instead of init_timer"

On 03/03/2017 01:46 PM, Jiri Slaby wrote:
> From: Lukáš Korenčik <xkorenc1@...muni.cz>
>
> Use inicialization with setup_timer function instead of using
> init_timer function and data fields. It improves readability.
>
> Signed-off-by: Lukáš Korenčik <xkorenc1@...muni.cz>
> Signed-off-by: Jiri Slaby <jslaby@...e.cz>
> Cc: Steffen Maier <maier@...ux.vnet.ibm.com>
> Cc: Martin Schwidefsky <schwidefsky@...ibm.com>
> Cc: Heiko Carstens <heiko.carstens@...ibm.com>
> Cc: <linux-s390@...r.kernel.org>
> ---
>  drivers/s390/scsi/zfcp_erp.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/s390/scsi/zfcp_erp.c b/drivers/s390/scsi/zfcp_erp.c
> index 7ccfce559034..14c0cbe335b3 100644
> --- a/drivers/s390/scsi/zfcp_erp.c
> +++ b/drivers/s390/scsi/zfcp_erp.c
> @@ -572,9 +572,8 @@ static void zfcp_erp_memwait_handler(unsigned long data)
>
>  static void zfcp_erp_strategy_memwait(struct zfcp_erp_action *erp_action)
>  {
> -	init_timer(&erp_action->timer);
> -	erp_action->timer.function = zfcp_erp_memwait_handler;
> -	erp_action->timer.data = (unsigned long) erp_action;
> +	setup_timer(&erp_action->timer, zfcp_erp_memwait_handler,
> +		(unsigned long) erp_action);
>  	erp_action->timer.expires = jiffies + HZ;
>  	add_timer(&erp_action->timer);
>  }
>

-- 
Mit freundlichen Grüßen / Kind regards
Steffen Maier

Linux on z Systems Development

IBM Deutschland Research & Development GmbH
Vorsitzende des Aufsichtsrats: Martina Koederitz
Geschaeftsfuehrung: Dirk Wittkopp
Sitz der Gesellschaft: Boeblingen
Registergericht: Amtsgericht Stuttgart, HRB 243294

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ