lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 15 Mar 2017 13:14:42 +0300
From:   Dan Carpenter <dan.carpenter@...cle.com>
To:     sunil.m@...hveda.org
Cc:     gregkh@...uxfoundation.org, devel@...verdev.osuosl.org,
        karthiknishu@...oo.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style

On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@...hveda.org wrote:
> @@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev)
>  
>  	for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) {
>  		priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev,
> -					      sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
> +		sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
>  					      &priv->rx_ring_dma[rx_queue_idx]);

No, don't do that.  The original was easier to read.  Ignore
checkpatch.pl if it gives you bad advice.

>  		if (!priv->rx_ring[rx_queue_idx] ||
>  		    (unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) {
> @@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
>  	int ret = -1;
>  	struct rtllib_device *ieee = priv->rtllib;
>  	u32 key[4];
> -	const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff};
> +	const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff,
> +									0xff};

Just drop this patch...  The original is better.

regards,
dan carpenter

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ