[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170315195527.703131481@goodmis.org>
Date: Wed, 15 Mar 2017 15:55:27 -0400
From: Steven Rostedt <rostedt@...dmis.org>
To: linux-kernel@...r.kernel.org
Cc: Ingo Molnar <mingo@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Thomas Gleixner <tglx@...utronix.de>,
Peter Zijlstra <peterz@...radead.org>,
Masami Hiramatsu <mhiramat@...nel.org>,
"H. Peter Anvin" <hpa@...or.com>,
Andy Lutomirski <luto@...capital.net>,
Josh Poimboeuf <jpoimboe@...hat.com>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: [RFC][PATCH 0/5] ftrace/x86_32: Ftrace cleanup and add support for -mfentry
With the issues of gcc screwing around with the mcount stack frame causing
function graph tracer to panic on x86_32, and with Linus saying that we
should start deprecating mcount (at least on x86), I figured that x86_32
needs to support fentry.
First, I renamed mcount_64.S to ftrace_64.S (hmm, my subject says ftrace.S,
oh well, this is still RFC, I'll fix that before posting). As we want to
get away from mcount, having the ftrace code in a file called mcount
seems rather backwards.
Next I moved the ftrace code out of entry_32.S. It's not in entry_64.S
and it does not belong in entry_32.S.
I noticed that the x86_32 code has the same issue as the x86_64 did
in the past with respect to a stack frame. I fixed that just for the main
ftrace_caller. The ftrace_regs_caller is rather special, and so is
function graph tracing.
I realized the ftrace_regs_caller code was complex due to me aggressively
saving flags, even though I could still do push, lea and mov without
changing them. That made the logic a little nicer.
Finally I added the fentry code.
I tested this (and I'm currently testing it) with an old compiler
(for mcount) with and without FRAME_POINTER set. I also did it with
a new compiler (with fentry), with and without FRAME_POINTER. I tested
function tracing, stack tracing, function_graph tracing, and kprobes
(as that uses the ftrace_regs_caller). So far this works. I'm still testing
but I'm confident enough with the current code to post an RFC.
Thoughts?
-- Steve
Steven Rostedt (VMware) (5):
x86/ftrace: Rename mcount_64.S to ftrace.S
ftrace/x86-32: Move the ftrace specific code out of entry_32.S
ftrace/x86_32: Add stack frame pointer to ftrace_caller
ftrace/x86_32: Clean up ftrace_regs_caller
ftrace/x86-32: Add -mfentry support to x86_32 with DYNAMIC_FTRACE set
----
Makefile | 12 +-
arch/x86/Kconfig | 2 +-
arch/x86/entry/entry_32.S | 168 -----------------
arch/x86/kernel/Makefile | 5 +-
arch/x86/kernel/ftrace_32.S | 257 +++++++++++++++++++++++++++
arch/x86/kernel/{mcount_64.S => ftrace_64.S} | 0
6 files changed, 267 insertions(+), 177 deletions(-)
create mode 100644 arch/x86/kernel/ftrace_32.S
rename arch/x86/kernel/{mcount_64.S => ftrace_64.S} (100%)
Powered by blists - more mailing lists