[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170323131818.GA21199@kroah.com>
Date: Thu, 23 Mar 2017 14:18:18 +0100
From: Greg KH <gregkh@...uxfoundation.org>
To: Arushi Singhal <arushisinghal19971997@...il.com>
Cc: w.d.hubbs@...il.com, devel@...verdev.osuosl.org, kirk@...sers.ca,
speakup@...ux-speakup.org, linux-kernel@...r.kernel.org,
outreachy-kernel@...glegroups.com, samuel.thibault@...-lyon.org,
chris@...-brannons.com
Subject: Re: [PATCH 02/11] staging: speakup: Remove multiple assignments
On Tue, Mar 21, 2017 at 05:12:26PM +0530, Arushi Singhal wrote:
> This patch fixes the checkpatch.pl warning "multiple assignments
> should be avoided."
>
> Signed-off-by: Arushi Singhal <arushisinghal19971997@...il.com>
> ---
> drivers/staging/speakup/main.c | 18 ++++++++++++------
> 1 file changed, 12 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c
> index f71206878363..f8fccc8bf6b2 100644
> --- a/drivers/staging/speakup/main.c
> +++ b/drivers/staging/speakup/main.c
> @@ -270,9 +270,12 @@ static unsigned char get_attributes(struct vc_data *vc, u16 *pos)
>
> static void speakup_date(struct vc_data *vc)
> {
> - spk_x = spk_cx = vc->vc_x;
> - spk_y = spk_cy = vc->vc_y;
> - spk_pos = spk_cp = vc->vc_pos;
> + spk_x = vc->vc_x;
> + spk_cx = spk_x;
> + spk_y = vc->vc_y;
> + spk_cy = spk_y;
> + spk_pos = vc->vc_pos;
> + spk_cp = spk_pos;
Ick, this is harder to read now, don't you think?
not good.
greg k-h
Powered by blists - more mailing lists