[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170329090852.lcc2viof7stxf7y6@hirez.programming.kicks-ass.net>
Date: Wed, 29 Mar 2017 11:08:52 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Davidlohr Bueso <dave@...olabs.net>
Cc: mingo@...nel.org, akpm@...ux-foundation.org, jack@...e.cz,
kirill.shutemov@...ux.intel.com, mhocko@...e.com,
mgorman@...hsingularity.net, linux-kernel@...r.kernel.org,
Davidlohr Bueso <dbueso@...e.de>
Subject: Re: [PATCH 1/5] locking: Introduce range reader/writer lock
On Mon, Mar 06, 2017 at 09:03:26PM -0800, Davidlohr Bueso wrote:
> +#define RANGE_RWLOCK_INFINITY (~0UL - 1)
> +#define DEFINE_RANGE_RWLOCK_INF(name) \
> + struct range_rwlock name = __RANGE_RWLOCK_INITIALIZER(0, RANGE_RWLOCK_INFINITY)
> +void range_rwlock_init_inf(struct range_rwlock *lock);
Ayes I'm a pendant, but that's a very small infinity. I always thought
infinity wasn't enumerable.
Can we think of a different name here? 'whole' / 'all' / 'full' ?
Powered by blists - more mailing lists