[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170406162857.GB24332@ulmo.ba.sec>
Date: Thu, 6 Apr 2017 18:28:57 +0200
From: Thierry Reding <thierry.reding@...il.com>
To: Laxman Dewangan <ldewangan@...dia.com>
Cc: robh+dt@...nel.org, jonathanh@...dia.com, mark.rutland@....com,
linux-pwm@...r.kernel.org, devicetree@...r.kernel.org,
linux-tegra@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH V2 1/4] pwm: tegra: Use DIV_ROUND_CLOSEST_ULL() instead
of local implementation
On Thu, Apr 06, 2017 at 07:50:58PM +0530, Laxman Dewangan wrote:
> Use macro DIV_ROUND_CLOSEST_ULL() for 64bit division to closet one
"closest"
Thierry
> instead of implementing the same locally. This increase readability.
>
> Signed-off-by: Laxman Dewangan <ldewangan@...dia.com>
> ---
> Changes from V1:
> None
>
> drivers/pwm/pwm-tegra.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/pwm/pwm-tegra.c b/drivers/pwm/pwm-tegra.c
> index e464784..0a688da 100644
> --- a/drivers/pwm/pwm-tegra.c
> +++ b/drivers/pwm/pwm-tegra.c
> @@ -85,8 +85,7 @@ static int tegra_pwm_config(struct pwm_chip *chip, struct pwm_device *pwm,
> * nearest integer during division.
> */
> c *= (1 << PWM_DUTY_WIDTH);
> - c += period_ns / 2;
> - do_div(c, period_ns);
> + c = DIV_ROUND_CLOSEST_ULL(c, period_ns);
>
> val = (u32)c << PWM_DUTY_SHIFT;
>
> --
> 2.1.4
>
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)
Powered by blists - more mailing lists