[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1492015203.28586.1.camel@perches.com>
Date: Wed, 12 Apr 2017 09:40:03 -0700
From: Joe Perches <joe@...ches.com>
To: Borislav Petkov <bp@...en8.de>,
Tyler Baicar <tbaicar@...eaurora.org>
Cc: christoffer.dall@...aro.org, marc.zyngier@....com,
pbonzini@...hat.com, rkrcmar@...hat.com, linux@...linux.org.uk,
catalin.marinas@....com, will.deacon@....com, rjw@...ysocki.net,
lenb@...nel.org, matt@...eblueprint.co.uk, robert.moore@...el.com,
lv.zheng@...el.com, nkaje@...eaurora.org, zjzhang@...eaurora.org,
mark.rutland@....com, james.morse@....com,
akpm@...ux-foundation.org, eun.taik.lee@...sung.com,
sandeepa.s.prabhu@...il.com, labbott@...hat.com,
shijie.huang@....com, rruigrok@...eaurora.org,
paul.gortmaker@...driver.com, tn@...ihalf.com, fu.wei@...aro.org,
rostedt@...dmis.org, bristot@...hat.com,
linux-arm-kernel@...ts.infradead.org, kvmarm@...ts.cs.columbia.edu,
kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-acpi@...r.kernel.org, linux-efi@...r.kernel.org,
devel@...ica.org, Suzuki.Poulose@....com, punit.agrawal@....com,
astone@...hat.com, harba@...eaurora.org, hanjun.guo@...aro.org,
john.garry@...wei.com, shiju.jose@...wei.com,
gengdongjiu@...wei.com, xiexiuqi@...wei.com
Subject: Re: [PATCH V14 02/10] ras: acpi/apei: cper: generic error data
entry v3 per ACPI 6.1
On Wed, 2017-04-12 at 15:34 +0200, Borislav Petkov wrote:
> On Tue, Mar 28, 2017 at 01:30:32PM -0600, Tyler Baicar wrote:
> > Currently when a RAS error is reported it is not timestamped.
[]
> > diff --git a/include/acpi/ghes.h b/include/acpi/ghes.h
[]
> > +#define acpi_hest_generic_data_error_length(gdata) \
> > + (((struct acpi_hest_generic_data *)(gdata))->error_data_length)
> > +#define acpi_hest_generic_data_size(gdata) \
> > + ((acpi_hest_generic_data_version(gdata) >= 3) ? \
> > + sizeof(struct acpi_hest_generic_data_v300) : \
> > + sizeof(struct acpi_hest_generic_data))
> > +#define acpi_hest_generic_data_record_size(gdata) \
> > + (acpi_hest_generic_data_size(gdata) + \
> > + acpi_hest_generic_data_error_length(gdata))
> > +#define acpi_hest_generic_data_next(gdata) \
> > + ((void *)(gdata) + acpi_hest_generic_data_record_size(gdata))
>
> This is one unreadable pile of too long names with a clearly redundant
> and too long prefix. Please shorten it all.
Naming is generally author's choice and internal
consistency has value too.
acpi_hest_generic<foo> is already used throughout this codebase
in multiple files and paths.
> > @@ -73,3 +85,13 @@ static inline void ghes_edac_unregister(struct ghes *ghes)
> > {
> > }
> > #endif
> > +
> > +#define acpi_hest_generic_data_version(gdata) \
> > + (gdata->revision >> 8)
> > +
> > +static inline void *acpi_hest_generic_data_payload(struct acpi_hest_generic_data *gdata)
>
> Lemme try to shorten it:
>
> static inline void *acpi_hest_get_payload(struct acpi_hest_gdata *d)
> {
> if (hest_gdata_ver(d) >= 3)
> return (void *)(((struct acpi_hest_gdata_v3 *)d) + 1);
> else
> return d + 1;
> }
>
> Now this is much more readable IMO. You can actually see what's going
> on. And you still know what the struct names are.
trivial: unnecessary cast to void *
Powered by blists - more mailing lists