lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 13 Apr 2017 10:53:26 +0200
From:   Johannes Thumshirn <jthumshirn@...e.de>
To:     Christoph Hellwig <hch@....de>
Cc:     Borislav Petkov <bp@...en8.de>,
        Sergey Temerkhanov <s.temerkhanov@...il.com>,
        linux-edac@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: please use pci_alloc_irq_vectors in thunderx_edac.

On Wed, Apr 12, 2017 at 07:30:22PM +0200, Christoph Hellwig wrote:
> > shows some have been done. I wonder whether marking
> > pci_enable_msix_exact() would cause a lot of warnings though. An
> > allyesconfig build would tell...
> 
> It would cause lots of warnings.  The problem with __deprecated is that
> it causes warnings for existing users, not just new ones.

So a checkpatch rule is the way to go, I guess.

-- 
Johannes Thumshirn                                          Storage
jthumshirn@...e.de                                +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850

Powered by blists - more mailing lists