[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170418082437.25451-2-linsh@oregonstate.edu>
Date: Tue, 18 Apr 2017 01:24:37 -0700
From: Chewie Lin <linsh@...gonstate.edu>
To: greg@...ah.com, forest@...ttletooquiet.net,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
Removed the usb_device_reset(), replace with call to usb_reset_device()
directly. Plus it removes the confusing function name and addressed
the checkpatch warning as well by swap string in the dev_warn() call with
__func__ argument, instead of explicitly calling the function name in
the string:
WARNING: Prefer using "%s", __func__ to embedded function names
#417: FILE: main_usb.c:417:
+ "usb_device_reset fail status=%d\n", status);
total: 0 errors, 1 warnings, 1058 lines checked
And after fix:
main_usb.c has no obvious style problems and is ready for submission.
Signed-off-by: Chewie Lin <linsh@...gonstate.edu>
---
drivers/staging/vt6656/main_usb.c | 15 ++++-----------
1 file changed, 4 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/vt6656/main_usb.c b/drivers/staging/vt6656/main_usb.c
index 9e074e9daf4e..028f54b453d0 100644
--- a/drivers/staging/vt6656/main_usb.c
+++ b/drivers/staging/vt6656/main_usb.c
@@ -407,16 +407,6 @@ static void vnt_free_rx_bufs(struct vnt_private *priv)
}
}
-static void usb_device_reset(struct vnt_private *priv)
-{
- int status;
-
- status = usb_reset_device(priv->usb);
- if (status)
- dev_warn(&priv->usb->dev,
- "usb_device_reset fail status=%d\n", status);
-}
-
static void vnt_free_int_bufs(struct vnt_private *priv)
{
kfree(priv->int_buf.data_buf);
@@ -995,7 +985,10 @@ vt6656_probe(struct usb_interface *intf, const struct usb_device_id *id)
SET_IEEE80211_DEV(priv->hw, &intf->dev);
- usb_device_reset(priv);
+ rc = usb_reset_device(priv->usb);
+ if (rc)
+ dev_warn(&priv->usb->dev,
+ "%s reset fail status=%d\n", __func__, rc);
clear_bit(DEVICE_FLAGS_DISCONNECTED, &priv->flags);
vnt_reset_command_timer(priv);
--
2.12.2
Powered by blists - more mailing lists