[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1492554972.8661.51.camel@perches.com>
Date: Tue, 18 Apr 2017 15:36:12 -0700
From: Joe Perches <joe@...ches.com>
To: Marek Vasut <marek.vasut@...il.com>,
Andrey Smirnov <andrew.smirnov@...il.com>,
linux-mtd@...ts.infradead.org
Cc: cphealy@...il.com, David Woodhouse <dwmw2@...radead.org>,
Brian Norris <computersforpeace@...il.com>,
Boris Brezillon <boris.brezillon@...e-electrons.com>,
Richard Weinberger <richard@....at>,
Cyrille Pitchen <cyrille.pitchen@...el.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 2/3] mtd: dataflash: Improve coding style in
jedec_probe()
On Tue, 2017-04-18 at 20:25 +0200, Marek Vasut wrote:
> On 04/18/2017 04:21 PM, Andrey Smirnov wrote:
> > As per request from Marek Vasut, change the following:
>
> Does that really have to be in the commit message ? ^_^'
>
> > - Replace indentation between type and name of local variable from
> > tabs to spaces
> >
> > - Replace magic number 0x1F with CFI_MFR_ATMEL macro
> >
> > - Replace variable 'tmp' with 'ret' and 'i' where appropriate
> >
> > - Reformat multi-line comments and add newlines where appropriate
> >
> > No functional change intended.
>
> Appreciated, thanks!
trivia:
> > diff --git a/drivers/mtd/devices/mtd_dataflash.c b/drivers/mtd/devices/mtd_dataflash.c
[]
> > @@ -768,9 +771,9 @@ static struct flash_info *jedec_probe(struct spi_device *spi)
> > jedec = jedec << 8;
> > jedec |= id[2];
> >
> > - for (tmp = 0, info = dataflash_data;
> > - tmp < ARRAY_SIZE(dataflash_data);
> > - tmp++, info++) {
> > + for (i = 0, info = dataflash_data;
> > + i < ARRAY_SIZE(dataflash_data);
> > + i++, info++) {
> > if (info->jedec_id == jedec) {
> > pr_debug("%s: OTP, sector protect%s\n",
> > dev_name(&spi->dev),
This loop could be written without the i variable.
for (info = dataflash_data;
info < dataflash_data + ARRAY_SIZE(dataflash_data);
info++) {
Powered by blists - more mailing lists