[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1493295756-17812-2-git-send-email-martin.kepplinger@ginzinger.com>
Date: Thu, 27 Apr 2017 14:22:36 +0200
From: Martin Kepplinger <martin.kepplinger@...zinger.com>
To: <dmitry.torokhov@...il.com>
CC: <linux-input@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
Martin Kepplinger <martin.kepplinger@...zinger.com>
Subject: [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number with definition
We now have a few of this device's definitions. Let's avoid magic numbers
and use them.
Signed-off-by: Martin Kepplinger <martin.kepplinger@...zinger.com>
---
drivers/input/touchscreen/ar1021_i2c.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/touchscreen/ar1021_i2c.c b/drivers/input/touchscreen/ar1021_i2c.c
index 2a76231..edd5268 100644
--- a/drivers/input/touchscreen/ar1021_i2c.c
+++ b/drivers/input/touchscreen/ar1021_i2c.c
@@ -44,7 +44,7 @@ static irqreturn_t ar1021_i2c_irq(int irq, void *dev_id)
goto out;
/* sync bit set ? */
- if ((data[0] & 0x80) == 0)
+ if ((data[0] & AR1021_TOUCH) == 0)
goto out;
button = data[0] & BIT(0);
--
2.1.4
Powered by blists - more mailing lists