[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20170430213701.12297-2-dtwlin@google.com>
Date: Sun, 30 Apr 2017 14:36:59 -0700
From: David Lin <dtwlin@...gle.com>
To: corbet@....net, rpurdie@...ys.net, jacek.anaszewski@...il.com,
pavel@....cz, hdegoede@...hat.com, mark.rutland@....com,
tony.makkiel@...ri.com, linz@...pro.net
Cc: robh@...nel.org, romlem@...gle.com, joelaf@...gle.com,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-leds@...r.kernel.org, David Lin <dtwlin@...gle.com>
Subject: [PATCH 1/3] leds: Replace flags bit shift with BIT() macros
This is for readability as well as to avoid checkpatch warnings when
adding new bit flag information in the future.
Signed-off-by: David Lin <dtwlin@...gle.com>
---
include/linux/leds.h | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/linux/leds.h b/include/linux/leds.h
index 64c56d454f7d..f9d10a9efcbe 100644
--- a/include/linux/leds.h
+++ b/include/linux/leds.h
@@ -43,12 +43,12 @@ struct led_classdev {
#define LED_SUSPENDED (1 << 0)
#define LED_UNREGISTERING (1 << 1)
/* Upper 16 bits reflect control information */
-#define LED_CORE_SUSPENDRESUME (1 << 16)
-#define LED_SYSFS_DISABLE (1 << 17)
-#define LED_DEV_CAP_FLASH (1 << 18)
-#define LED_HW_PLUGGABLE (1 << 19)
-#define LED_PANIC_INDICATOR (1 << 20)
-#define LED_BRIGHT_HW_CHANGED (1 << 21)
+#define LED_CORE_SUSPENDRESUME BIT(16)
+#define LED_SYSFS_DISABLE BIT(17)
+#define LED_DEV_CAP_FLASH BIT(18)
+#define LED_HW_PLUGGABLE BIT(19)
+#define LED_PANIC_INDICATOR BIT(20)
+#define LED_BRIGHT_HW_CHANGED BIT(21)
/* set_brightness_work / blink_timer flags, atomic, private. */
unsigned long work_flags;
--
2.13.0.rc0.306.g87b477812d-goog
Powered by blists - more mailing lists