lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sun, 30 Apr 2017 19:05:10 +1000
From:   "Tobin C. Harding" <me@...in.cc>
To:     Dan Carpenter <dan.carpenter@...cle.com>
Cc:     Ilia Sergachev <ilia.sergachev@...bas.ch>,
        devel@...verdev.osuosl.org,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] staging: ks7010: remove line continuations in quoted
 strings

On Fri, Apr 28, 2017 at 05:26:17PM +0300, Dan Carpenter wrote:
> On Fri, Apr 28, 2017 at 04:19:28PM +0200, Ilia Sergachev wrote:
> > Checkpatch emits WARNING: Avoid line continuations in quoted strings.
> > 
> > Remove line continuations - split strings using quotes.
> > 
> > Signed-off-by: Ilia Sergachev <ilia.sergachev@...bas.ch>
> > ---
> >  drivers/staging/ks7010/ks_hostif.c | 20 ++++++++++++++------
> >  1 file changed, 14 insertions(+), 6 deletions(-)
> > 
> > diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c
> > index 7151f16e2f9c..a0c632a52f48 100644
> > --- a/drivers/staging/ks7010/ks_hostif.c
> > +++ b/drivers/staging/ks7010/ks_hostif.c
> > @@ -191,9 +191,15 @@ int get_current_ap(struct ks_wlan_private *priv, struct link_ap_info_t *ap_info)
> >  		wireless_send_event(netdev, SIOCGIWAP, &wrqu, NULL);
> >  	}
> >  	DPRINTK(4, "\n    Link AP\n");
> > -	DPRINTK(4, "    bssid=%02X:%02X:%02X:%02X:%02X:%02X\n \
> > -   essid=%s\n    rate_set=%02X,%02X,%02X,%02X,%02X,%02X,%02X,%02X\n    channel=%d\n \
> > -   rssi=%d\n    sq=%d\n    capability=%04X\n", ap->bssid[0], ap->bssid[1], ap->bssid[2], ap->bssid[3], ap->bssid[4], ap->bssid[5], &(ap->ssid.body[0]), ap->rate_set.body[0], ap->rate_set.body[1], ap->rate_set.body[2], ap->rate_set.body[3], ap->rate_set.body[4], ap->rate_set.body[5], ap->rate_set.body[6], ap->rate_set.body[7], ap->channel, ap->rssi, ap->sq, ap->capability);
> > +	DPRINTK(4, "    bssid=%02X:%02X:%02X:%02X:%02X:%02X\n"
> > +	"    essid=%s\n    rate_set=%02X,%02X,%02X,%02X,%02X,%02X,%02X,%02X\n"
> > +	"    channel=%d\n    rssi=%d\n    sq=%d\n    capability=%04X\n",
> > +	ap->bssid[0], ap->bssid[1], ap->bssid[2],
> > +	ap->bssid[3], ap->bssid[4], ap->bssid[5],
> > +	&(ap->ssid.body[0]), ap->rate_set.body[0], ap->rate_set.body[1],
> > +	ap->rate_set.body[2], ap->rate_set.body[3], ap->rate_set.body[4],
> > +	ap->rate_set.body[5], ap->rate_set.body[6], ap->rate_set.body[7],
> > +	ap->channel, ap->rssi, ap->sq, ap->capability);
> 
> Could you indent it like this:
> 
> 	DPRINTK(4, "    bssid=%02X:%02X:%02X:%02X:%02X:%02X\n"
> 		   "    essid=%s\n    rate_set=%02X,%02X,%02X,%02X,%02X,%02X,%02X,%02X\n"
> 		   "    channel=%d\n    rssi=%d\n    sq=%d\n    capability=%04X\n",
> 		ap->bssid[0], ap->bssid[1], ap->bssid[2],
> 		ap->bssid[3], ap->bssid[4], ap->bssid[5],
> 		&(ap->ssid.body[0]), ap->rate_set.body[0], ap->rate_set.body[1],
> 		ap->rate_set.body[2], ap->rate_set.body[3], ap->rate_set.body[4],
> 		ap->rate_set.body[5], ap->rate_set.body[6], ap->rate_set.body[7],
> 		ap->channel, ap->rssi, ap->sq, ap->capability);
> 
> And actually it might be more readable to break it up more:
> 
> 	DPRINTK(4, "    bssid=%02X:%02X:%02X:%02X:%02X:%02X\n"
> 		   "    essid=%s\n"
> 		   "    rate_set=%02X,%02X,%02X,%02X,%02X,%02X,%02X,%02X\n"
> 		   "    channel=%d\n"
> 		   "    rssi=%d\n"
> 		   "    sq=%d\n"
> 		   "    capability=%04X\n",
> 		ap->bssid[0], ap->bssid[1], ap->bssid[2],
> 		ap->bssid[3], ap->bssid[4], ap->bssid[5],
> 		&(ap->ssid.body[0]), ap->rate_set.body[0], ap->rate_set.body[1],
> 		ap->rate_set.body[2], ap->rate_set.body[3], ap->rate_set.body[4],
> 		ap->rate_set.body[5], ap->rate_set.body[6], ap->rate_set.body[7],
> 		ap->channel, ap->rssi, ap->sq, ap->capability);
> 
> Except that's not really how newlines are supposed to work in dmesg...
> Whatever.

This driver is full of these DPRINTK's, I would like to see them gone
once some more testing is done. I don't see any nice way to keep them
without upsetting checkpatch. It may not be worth bothering with them
for now.

thanks,
Tobin.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ