[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <59070AD5.7030405@mentor.com>
Date: Mon, 1 May 2017 03:15:49 -0700
From: Jiada Wang <jiada_wang@...tor.com>
To: Mark Brown <broonie@...nel.org>
CC: <linux-spi@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<fixed-term.Oleksij.Rempel@...bosch.com>
Subject: Re: [PATCH 1/2] spi: imx: dynamic burst length adjust for PIO mode
Hello Mark
Sorry, somehow I missed your following comment
On 02/14/2017 10:20 AM, Mark Brown wrote:
> On Wed, Feb 08, 2017 at 03:20:27PM +0900, Jiada Wang wrote:
>
> This looks basically fine, a couple of fairly minor things here:
>
>> + for (i = 0; i< transfer->len / 4; i++) {
>> + u8 temp;
>> +
>> + temp = *(buf + i * 4);
>> + *(buf + i * 4) = *(buf + i * 4 + 3);
>> + *(buf + i * 4 + 3) = temp;
> Should this be using one of the cpu_to_ functions? It's a bit unclear
> what the goal is here and if it'll work if the kernel is big endian
> (which people do do with i.MX systems IIRC).
indeed, with big endian kernel, this function won't work
I will replace the algo here with cpu_to_* in next version
Thanks,
Jiada
>> + if (spi_imx->bpw_w == 1)
>> + spi_imx_buf_rx_u8(spi_imx);
>> + else if (spi_imx->bpw_w == 2)
>> + spi_imx_buf_rx_u16(spi_imx);
> switch statement please.
>
>> + if (spi_imx->dynamic_burst) {
>> + spi_imx->count_index =
>> + spi_imx->count> MX51_ECSPI_CTRL_MAX_BURST ?
>> + spi_imx->count % MX51_ECSPI_CTRL_MAX_BURST :
>> + spi_imx->count % sizeof(u32);
> Just write a normal if statement please, it's easier to read.
Powered by blists - more mailing lists