[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <bbdddc0b-0435-21f2-bb35-10779e54f102@gmail.com>
Date: Mon, 8 May 2017 22:24:19 +0200
From: Jacek Anaszewski <jacek.anaszewski@...il.com>
To: David Lin <dtwlin@...gle.com>, corbet@....net, rpurdie@...ys.net,
pavel@....cz, hdegoede@...hat.com, mark.rutland@....com,
tony.makkiel@...ri.com, linz@...pro.net
Cc: robh@...nel.org, romlem@...gle.com, joelaf@...gle.com,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-leds@...r.kernel.org
Subject: Re: [PATCH 1/3] leds: Replace flags bit shift with BIT() macros
Hi David,
On 04/30/2017 11:36 PM, David Lin wrote:
> This is for readability as well as to avoid checkpatch warnings when
> adding new bit flag information in the future.
>
> Signed-off-by: David Lin <dtwlin@...gle.com>
> ---
> include/linux/leds.h | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/include/linux/leds.h b/include/linux/leds.h
> index 64c56d454f7d..f9d10a9efcbe 100644
> --- a/include/linux/leds.h
> +++ b/include/linux/leds.h
> @@ -43,12 +43,12 @@ struct led_classdev {
> #define LED_SUSPENDED (1 << 0)
> #define LED_UNREGISTERING (1 << 1)
Could we update also these bits?
> /* Upper 16 bits reflect control information */
> -#define LED_CORE_SUSPENDRESUME (1 << 16)
> -#define LED_SYSFS_DISABLE (1 << 17)
> -#define LED_DEV_CAP_FLASH (1 << 18)
> -#define LED_HW_PLUGGABLE (1 << 19)
> -#define LED_PANIC_INDICATOR (1 << 20)
> -#define LED_BRIGHT_HW_CHANGED (1 << 21)
> +#define LED_CORE_SUSPENDRESUME BIT(16)
> +#define LED_SYSFS_DISABLE BIT(17)
> +#define LED_DEV_CAP_FLASH BIT(18)
> +#define LED_HW_PLUGGABLE BIT(19)
> +#define LED_PANIC_INDICATOR BIT(20)
> +#define LED_BRIGHT_HW_CHANGED BIT(21)
>
> /* set_brightness_work / blink_timer flags, atomic, private. */
> unsigned long work_flags;
>
--
Best regards,
Jacek Anaszewski
Powered by blists - more mailing lists