lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 25 May 2017 10:08:14 +0200
From:   Jiri Olsa <jolsa@...hat.com>
To:     David Carrillo-Cisneros <davidcc@...gle.com>
Cc:     linux-kernel@...r.kernel.org,
        Peter Zijlstra <peterz@...radead.org>,
        Ingo Molnar <mingo@...hat.com>,
        Arnaldo Carvalho de Melo <acme@...nel.org>,
        Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
        Andi Kleen <ak@...ux.intel.com>, Simon Que <sque@...omium.org>,
        Wang Nan <wangnan0@...wei.com>, Jiri Olsa <jolsa@...nel.org>,
        He Kuang <hekuang@...wei.com>,
        Masami Hiramatsu <mhiramat@...nel.org>,
        David Ahern <dsa@...ulusnetworks.com>,
        Namhyung Kim <namhyung@...nel.org>,
        Stephane Eranian <eranian@...gle.com>,
        Paul Turner <pjt@...gle.com>
Subject: Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros

On Tue, May 23, 2017 at 12:48:51AM -0700, David Carrillo-Cisneros wrote:

SNIP

> -#define FEAT_OPA(n, func) \
> -	[n] = { .name = #n, .write = write_##func, .print = print_##func }
> -#define FEAT_OPP(n, func) \
> -	[n] = { .name = #n, .write = write_##func, .print = print_##func, \
> -		.process = process_##func }
> -#define FEAT_OPF(n, func) \
> -	[n] = { .name = #n, .write = write_##func, .print = print_##func, \
> -		.process = process_##func, .full_only = true }
> +#define FEAT_OPR(n, func, __full_only) \
> +	[HEADER_##n] = {					\
> +		.name = __stringify(HEADER_##n),		\
> +		.write = write_##func,				\
> +		.print = print_##func,				\
> +		.full_only = __full_only,			\
> +		.process = process_##func,			\
> +		.has_record = true				\
> +	}
> +
> +#define FEAT_OPN(n, func, __full_only) \
> +	[HEADER_##n] = {					\
> +		.name = __stringify(HEADER_##n),		\
> +		.write = write_##func,				\
> +		.print = print_##func,				\
> +		.full_only = __full_only,			\
> +		.process = process_##func			\
> +	}

could you please align this (and in other places of the patchset), like:

	.name		= __stringify(HEADER_##n),	\
	.write		= write_##func,			\
	.print		= print_##func,			\
	.full_only	= __full_only,			\
	.process	= process_##func		\

much more readable..

thanks,
jirka

Powered by blists - more mailing lists