lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 1 Jun 2017 09:16:59 -0500
From:   Josh Poimboeuf <jpoimboe@...hat.com>
To:     Andy Lutomirski <luto@...nel.org>
Cc:     X86 ML <x86@...nel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        live-patching@...r.kernel.org,
        Linus Torvalds <torvalds@...ux-foundation.org>,
        Jiri Slaby <jslaby@...e.cz>, Ingo Molnar <mingo@...nel.org>,
        "H. Peter Anvin" <hpa@...or.com>,
        Peter Zijlstra <peterz@...radead.org>
Subject: Re: [RFC PATCH 05/10] objtool, x86: add facility for asm code to
 provide CFI hints

On Thu, Jun 01, 2017 at 06:57:24AM -0700, Andy Lutomirski wrote:
> On Wed, May 31, 2017 at 10:44 PM, Josh Poimboeuf <jpoimboe@...hat.com> wrote:
> > Some asm (and inline asm) code does special things to the stack which
> > objtool can't understand.  (Nor can GCC or GNU assembler, for that
> > matter.)  In such cases we need a facility for the code to provide
> > annotations, so the unwinder can unwind through it.
> >
> > This provides such a facility, in the form of CFI hints.  They're
> > similar to the GNU assembler .cfi* directives, but they give more
> > information, and are needed in far fewer places, because objtool can
> > fill in the blanks by following branches and adjusting the stack pointer
> > for pushes and pops.
> 
> Two minor suggestions:
> 
> Could you prefix these with something other than "CFI_"?  For those of
> use who have read the binutils manual, using "CFI_" sounds awfully
> like .cfi_, and people might expect the semantics to be the same.

The intention was that even if this undwarf thing doesn't work out, the
CFI_ macros could still be used by objtool to generate proper DWARF.
Would prefixing them with CFI_HINT_ be better?  Or UNWIND_HINT_?

> > +#define CFI_HINT(cfa_reg, cfa_offset, type)                    \
> > +       "999: \n\t"                                             \
> 
> Have you checked if 999 is used elsewhere?  My personal preference is to use:
> 
> .Ldescriptive_text_\@:
> 
> instead of a hopefully-unique number.  I never researched the history,
> but I suspect that the convention of using large numbers came from
> early binutils versions that didn't have \@, but we use \@ fairly
> extensively in the kernel these days, so it would seem that we no
> longer support binutils versions that old.

Yeah, that would be a lot better, thanks.

-- 
Josh

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ